Search found 7 matches

by manjuk123
Thu May 23, 2019 12:53 pm
Forum: ESP IoT Solution
Topic: ssd1306 oled on i2c not showing up ( esp Azure iot kit )
Replies: 13
Views: 2298

Re: ssd1306 oled on i2c not showing up ( esp Azure iot kit )

@ESP_Sprite Sorry for late reply. I saw your reply yesterday because this forum ui confused me a little and your reply was on the page 2 and I thought all the replies will be in the same page. I bought a USB logic analyzer, i dont know how to debug it with this board. can you guide me or give me som...
by manjuk123
Thu May 09, 2019 9:47 am
Forum: ESP IoT Solution
Topic: ssd1306 oled on i2c not showing up ( esp Azure iot kit )
Replies: 13
Views: 2298

Re: ssd1306 oled on i2c not showing up ( esp Azure iot kit )

@ESP_Sprite I tried but still no data from any sensors.
by manjuk123
Thu May 09, 2019 7:05 am
Forum: ESP IoT Solution
Topic: ssd1306 oled on i2c not showing up ( esp Azure iot kit )
Replies: 13
Views: 2298

Re: ssd1306 oled on i2c not showing up ( esp Azure iot kit )

@ESP_Sprite any thought on this behavior
by manjuk123
Wed May 08, 2019 6:48 am
Forum: ESP IoT Solution
Topic: ssd1306 oled on i2c not showing up ( esp Azure iot kit )
Replies: 13
Views: 2298

Re: ssd1306 oled on i2c not showing up ( esp Azure iot kit )

No I haven't connected anything to board. I have powered up the board through USB. From debugging what i got to know is SDA value is always 0 and SCL value remains 1.
by manjuk123
Tue May 07, 2019 10:31 am
Forum: ESP IoT Solution
Topic: ssd1306 oled on i2c not showing up ( esp Azure iot kit )
Replies: 13
Views: 2298

Re: ssd1306 oled on i2c not showing up ( esp Azure iot kit )

@ESP_Sprite Board : Esp Azure IOT kit It has temperature/humidity, light, motion etc,., sensors. Everything was working perfectly working when i bought it. I flashed a example code from esp-iot-solution repo and suddenly led stopped working, now all the sensors stopped working. when i scan for i2c d...
by manjuk123
Fri May 03, 2019 4:29 am
Forum: ESP IoT Solution
Topic: ssd1306 oled on i2c not showing up ( esp Azure iot kit )
Replies: 13
Views: 2298

ssd1306 oled on i2c not showing up ( esp Azure iot kit )

I used esp32_azure_iot_kit example code from this repo. I tried using esp_tool to scan for available devices, Except OLED ( addr: 0x3c ) other sensors are showing up. Below is the result on i2cdetect Scanning I2C Addresses .. .. .. .. .. .. .. .. .. .. .. .. .. .. 0E .. .. .. .. .. .. .. .. .. .. .....

Go to advanced search