Search found 39 matches

by chadpham75
Tue Jan 28, 2020 7:18 pm
Forum: ESP-IDF
Topic: How to find the image size for OTA
Replies: 7
Views: 1841

Re: How to find the image size for OTA

@boarchuz,
Thank you. I already made the decision to have the server's team help in this sizeof thing. I just try to see if there is api provide by ESP to support this, but I understand now it is not their responsibilities.
by chadpham75
Tue Jan 28, 2020 5:59 am
Forum: ESP-IDF
Topic: How to find the image size for OTA
Replies: 7
Views: 1841

Re: How to find the image size for OTA

Hi all, If you have a chance go over this thread, please simply just leave a message either "me too" or "+1". I am just curiously how many people are looking for the same solution/method. I can see the number of people who read this post increasingly but nothing/no comment. May be if may be too many...
by chadpham75
Sun Jan 26, 2020 2:52 am
Forum: ESP-IDF
Topic: How to find the image size for OTA
Replies: 7
Views: 1841

Re: How to find the image size for OTA

@ESP_Mahavir, Thank you for the suggestion, but the snippet you suggest only give me the number of byte the successfully download and write to flash each esp_https_ota_perform() function call. It won't help what I am looking for. What I am looking for is the whole image's size before the download is...
by chadpham75
Fri Jan 24, 2020 10:33 pm
Forum: ESP-IDF
Topic: How to find the image size for OTA
Replies: 7
Views: 1841

Re: How to find the image size for OTA

Anyone? Any suggestion?
by chadpham75
Fri Jan 24, 2020 4:08 am
Forum: ESP-IDF
Topic: Secure Boot and Flash Encryption with Release Mode did not work
Replies: 5
Views: 1126

Re: Secure Boot and Flash Encryption with Release Mode did not work

Guys,
Forget about v4.1-dev, I end up to use v4.0-rc. No helps what so ever posted here.
by chadpham75
Fri Jan 24, 2020 4:03 am
Forum: ESP-IDF
Topic: v4.1-dev https_OTA is not working
Replies: 7
Views: 2186

Re: v4.1-dev https_OTA is not working

@ESP-MJ, please follow exactly the instruction by Espressif here https://github.com/espressif/esp-idf/tree/master/examples/system/ota There is nothing else need to be done differently with self-sign server setup, the only thing change is the SDK between v4.0-beta1 vs. v4.1-dev @kkentzo, I gave up in...
by chadpham75
Fri Jan 17, 2020 5:24 am
Forum: ESP-IDF
Topic: NVS Encryption is not working with V4.0-Release
Replies: 0
Views: 699

NVS Encryption is not working with V4.0-Release

Hi all, I tried to implement the NVS Encryption with version V4.0-Release. I followed this https://docs.espressif.com/projects/esp-idf/en/latest/api-reference/storage/nvs_flash.html#nvs-encryption . I used the example nvs_rw_blob with the addition of the code if (!esp_flash_encryption_enabled()) { p...
by chadpham75
Thu Jan 16, 2020 9:34 am
Forum: ESP-IDF
Topic: How to find the image size for OTA
Replies: 7
Views: 1841

How to find the image size for OTA

Hi all,
Do any of you know how can find the download image's size at the time we check for the image's description at the beginning of the OTA? I would like to show the status of the download by using the percentage of the image's size since I do know the image_len_read.
by chadpham75
Wed Jan 08, 2020 6:15 pm
Forum: ESP-IDF
Topic: Secure Boot and Flash Encryption with Release Mode did not work
Replies: 5
Views: 1126

Re: Secure Boot and Flash Encryption with Release Mode did not work

Hi Angus,
I am using v4.1-dev-1757-g826b9f638-dirty. Is there any suggestion for what I should try next?
Thank you for your helps.
by chadpham75
Wed Jan 08, 2020 8:20 am
Forum: ESP-IDF
Topic: v4.1-dev https_OTA is not working
Replies: 7
Views: 2186

v4.1-dev https_OTA is not working

Hi guys, I think the v4.1-dev has an issue with OTA. I am using version v4.1-dev-1770-g71b4768df-dirty. Previously, I tested the version v4.0-beta2, and the simple_ota_example is working correctly when I followed this https://github.com/espressif/esp-idf/tree/master/examples/system/ota Due to the pr...

Go to advanced search