Search found 10 matches

by JadElClemens
Tue Feb 18, 2020 7:00 pm
Forum: ESP32 IDF
Topic: [SOLVED] Writing OTA bootup tests in Unity
Replies: 0
Views: 217

[SOLVED] Writing OTA bootup tests in Unity

Hey all, I'm starting to implement OTA updates and am wondering if it's possible to write the OTA first boot verification tests in Unity. I have been meaning to write unit tests for a while, so it seems like this is a two birds one stone type of situation. The only problem is that I don't see any fa...
by JadElClemens
Thu Feb 13, 2020 9:37 pm
Forum: ESP32 IDF
Topic: Multiple subprojects within one project
Replies: 0
Views: 514

Multiple subprojects within one project

Hey all, I'm getting started with OTA updates and was wondering about workflows for building factory vs. production apps. Ideally I want my factory application to use a stripped-down set of the code written for my production app. In order to do this without muddling up the code with a ton of #ifdefs...
by JadElClemens
Tue Nov 26, 2019 9:45 pm
Forum: ESP32 IDF
Topic: BLE Provisioning failure with NimBLE stack only
Replies: 0
Views: 231

BLE Provisioning failure with NimBLE stack only

Hey all, I've implemented WiFi provisioning using the WiFi Provisioning Manager component. I've tested out the SoftAP transport and am working on trying the BLE transport as well so I can compare the two experiences. Some background: I'm using the Security0 option for provisioning but may move to Se...
by JadElClemens
Thu Nov 14, 2019 5:46 pm
Forum: ESP32 IDF
Topic: TCPIP get/set hostname always fails
Replies: 4
Views: 535

Re: TCPIP get/set hostname always fails

Sure thing

https://privatebin.net/?239d6ac0b61a402 ... GsALbqeBCt

I removed some irrelevant parts and personal log information that had nothing to do with the WiFi subsystem.
by JadElClemens
Tue Nov 12, 2019 11:02 pm
Forum: ESP32 IDF
Topic: TCPIP get/set hostname always fails
Replies: 4
Views: 535

TCPIP get/set hostname always fails

I noticed since upgrading to ESP-IDF v4.0-beta2 from v3.2 that my calls to tcpip_adapter_{get,set}_hostname now fail. The error code for getting the hostname is ESP_ERR_TCPIP_ADAPTER_INVALID_PARAMS and for setting it is ESP_ERR_TCPIP_ADAPTER_IF_NOT_READY, though I can say with confidence that in bot...
by JadElClemens
Mon Nov 11, 2019 10:19 pm
Forum: ESP32 IDF
Topic: Section start and stop markers in Linker Fragments
Replies: 0
Views: 230

Section start and stop markers in Linker Fragments

Hey all, My project uses some linker magic for a specific class of variables in the code in order to group them all together and iterate over them for initialization. The developer before me implemented this by inserting start and stop markers as linker symbols into the project linker script (previo...
by JadElClemens
Tue Oct 29, 2019 10:27 pm
Forum: ESP32 IDF
Topic: Long delay after UART transmit
Replies: 5
Views: 514

Re: Long delay after UART transmit

An update: Using the built-in RS485 half-duplex mode and just inverting the RTS line when talking to the secondary endpoint seems to have solved the problem for me. By default, it's un-pinned so it can run on either CPU and its priority is 18 (for memory), so it would preempt the UART task on CPU1 i...
by JadElClemens
Tue Oct 29, 2019 5:25 pm
Forum: ESP32 IDF
Topic: Long delay after UART transmit
Replies: 5
Views: 514

Re: Long delay after UART transmit

Hi JadElClemens, Try setting this config item to pin the LWIP TCP/IP task to core 0: https://docs.espressif.com/projects/esp-idf/en/v3.2/api-reference/kconfig.html#config-tcpip-task-affinity By default, it's un-pinned so it can run on either CPU and its priority is 18 (for memory), so it would pree...
by JadElClemens
Tue Oct 29, 2019 12:08 am
Forum: ESP32 IDF
Topic: Long delay after UART transmit
Replies: 5
Views: 514

Re: Long delay after UART transmit

Thanks for the quick reply. Which ESP-IDF version do you have? I'm using v3.2 Do you have Wi-Fi or BT enabled at the same time? WiFi is enabled, Bluetooth is not. When you say you raised the priority "above all other tasks", how high did you raise it? I suppose I mean that I raised it above the prio...
by JadElClemens
Mon Oct 28, 2019 9:31 pm
Forum: ESP32 IDF
Topic: Long delay after UART transmit
Replies: 5
Views: 514

Long delay after UART transmit

Hey all, I'm writing code for an ESP32 to talk to two devices over the same UART line using an RS485 multiplexing setup. Because my setup is not standard, I have been hesitant to use the IDF's built-in RS485 mode and instead have opted to manually control the TX/RX select line in my communications a...

Go to advanced search