Search found 8 matches

by kurtnelle
Thu Feb 20, 2020 12:19 am
Forum: Hardware
Topic: Debugging DevKitv3 with Visual GDB
Replies: 11
Views: 1770

Re: Debugging DevKitv3 with Visual GDB

After much frustration I have decided the following:
IMG_20200219_201631.jpg
IMG_20200219_201631.jpg (455.04 KiB) Viewed 400 times
Problem solved.
by kurtnelle
Wed Feb 19, 2020 2:54 am
Forum: Hardware
Topic: Debugging DevKitv3 with Visual GDB
Replies: 11
Views: 1770

Re: Debugging DevKitv3 with Visual GDB

...and there are no other jtag devices on the system.
by kurtnelle
Wed Feb 19, 2020 1:11 am
Forum: Hardware
Topic: Debugging DevKitv3 with Visual GDB
Replies: 11
Views: 1770

Re: Debugging DevKitv3 with Visual GDB

Jumpers Ahoy!
IMG_20200218_204604.jpg
IMG_20200218_204604.jpg (754.92 KiB) Viewed 1026 times
IMG_20200218_204553.jpg
IMG_20200218_204553.jpg (641.94 KiB) Viewed 1026 times
by kurtnelle
Mon Feb 17, 2020 11:37 pm
Forum: Hardware
Topic: Debugging DevKitv3 with Visual GDB
Replies: 11
Views: 1770

Re: Debugging DevKitv3 with Visual GDB

I erased the program. Same problem. Problem persists. Same screenshot. Same error message.
by kurtnelle
Mon Feb 17, 2020 4:41 pm
Forum: Hardware
Topic: Debugging DevKitv3 with Visual GDB
Replies: 11
Views: 1770

Re: Debugging DevKitv3 with Visual GDB

" If this program redefines GPIO12-15 to do something else, JTAG won't work" -- that makes some sense. I will invoke esptool.py to erase the flash and try again. Who knows?!
by kurtnelle
Sun Feb 16, 2020 8:57 pm
Forum: Hardware
Topic: Debugging DevKitv3 with Visual GDB
Replies: 11
Views: 1770

Re: Debugging DevKitv3 with Visual GDB

Yes, I went through ( https://docs.espressif.com/projects/esp ... it-v3.html ) several times.
by kurtnelle
Sat Feb 15, 2020 7:20 pm
Forum: Hardware
Topic: Debugging DevKitv3 with Visual GDB
Replies: 11
Views: 1770

Re: Debugging DevKitv3 with Visual GDB

I guess I must be asking the impossible. :shock:
by kurtnelle
Thu Feb 13, 2020 9:24 pm
Forum: Hardware
Topic: Debugging DevKitv3 with Visual GDB
Replies: 11
Views: 1770

Debugging DevKitv3 with Visual GDB

Annotation 2020-02-13 014504.png I have version 3 of the wrover dev kit. I need to set it up so that I can debug using Visual GDB, but I get this error output (see attached) when I test the connection. Visual GDB support says that it's a problem in how the device is setup/connected. How do I setup ...

Go to advanced search