Search found 5 matches

by Sweaps
Wed Sep 23, 2020 8:57 am
Forum: ESP-IDF
Topic: WROVER-E Secure Boot V2 and Debugging
Replies: 3
Views: 442

Re: WROVER-E Secure Boot V2 and Debugging

Hi samc77, Well I have found in the espressif docs that it is not possible to use software breakpoints ( https://docs.espressif.com/projects/esp-idf/en/latest/esp32/api-guides/jtag-debugging/tips-and-quirks.html#jtag-debugging-security-features ). I saw that they just released the v4.1 tag on ESP-ID...
by Sweaps
Tue Sep 22, 2020 9:52 am
Forum: ESP-IDF
Topic: WROVER-E Secure Boot V2 and Debugging
Replies: 3
Views: 442

Re: WROVER-E Secure Boot V2 and Debugging

Hi,

I have the exact same problem on my chip. Have you updated your problem ? :)
by Sweaps
Fri Sep 11, 2020 1:58 pm
Forum: General Discussion
Topic: NVS set the same value as stored in nvs partition
Replies: 3
Views: 227

Re: NVS set the same value as stored in nvs partition

Hello ESP_Sprite, Sorry, maybe my question was unclear. What happens if I do this ? nvs_open(handle); nvs_set_i8(handle, "myKey", 1) ; nvs_commit(handle); nvs_close(handle); nvs_open(handle); nvs_set_i8(handle, "myKey", 1) ; nvs_commit(handle); nvs_close(handle); I save the same value which is 1 on ...
by Sweaps
Thu Sep 10, 2020 1:51 pm
Forum: General Discussion
Topic: NVS set the same value as stored in nvs partition
Replies: 3
Views: 227

NVS set the same value as stored in nvs partition

Hello, I'm working on ESP-IDF v4.0.1 I would like to know what happens if I call nvs_set_* and I already have got the same value stored in my nvs partition ? In my code, I don't know if I need to check the previous value stored before storing a new one and I don't find a good information into the do...
by Sweaps
Fri May 29, 2020 7:08 am
Forum: General Discussion
Topic: ESP32-dev-kitc MQTT SSL Muthual auth. cannot connect
Replies: 0
Views: 299

ESP32-dev-kitc MQTT SSL Muthual auth. cannot connect

Hello, I got to create a project using MQTT with SSL Muthual auth., so I used the example project from ESP-IDF, it is going perfectly everytime I try to connect to my broker with ECDSA key type and SHA-256. Then I try to run it on my project with the same sample code to connect and I got a mbed_ssl ...

Go to advanced search