Search found 77 matches

by rsimpsonbusa
Sat Jun 13, 2020 9:36 pm
Forum: General Discussion
Topic: How to deny Connection as AP
Replies: 4
Views: 951

Re: How to deny Connection as AP

Hi. I don’t have panics or heap errors. I have very strict control of any structure or Mallocs that the station was using. Also, the intention was to deny an external station to connect at all so I have a list of whitelisted macs and therefore when a AP_STA_CONNECT happens and not in the whitelist i...
by rsimpsonbusa
Wed May 27, 2020 4:52 am
Forum: ESP32 IDF
Topic: WinBond 16MB 133MHZ Flash not working
Replies: 4
Views: 402

Re: WinBond 16MB 133MHZ Flash not working

Hi ESP_Angus Well Im so embarrassed. I thought I bought a 16MByte chip (128Mb) but actually I got a 2MByte (16Mb) chip. :o So All the problem is that it does not have the capacity, and it actually identifies the chip correctly as well as the capacity (2mega bytes 1<<0x15). The log showed that and th...
by rsimpsonbusa
Wed May 27, 2020 2:35 am
Forum: ESP32 IDF
Topic: WinBond 16MB 133MHZ Flash not working
Replies: 4
Views: 402

Re: WinBond 16MB 133MHZ Flash not working

Hi ESP_Angus The esp32 wroom-32 flash chip was replaced by the winbond, so no new pcb or related pcb design errors/noise. The 8 pins where tested for continuity to the "external pins" (since the cap was removed). The environment is an app that is working with the default esp23 flash chip from XMC. I...
by rsimpsonbusa
Tue May 26, 2020 3:36 pm
Forum: ESP32 IDF
Topic: WinBond 16MB 133MHZ Flash not working
Replies: 4
Views: 402

WinBond 16MB 133MHZ Flash not working

Hi everybody. Hope all well at home and family. Does anybody know if a winbond W25Q16VSSIG (https://www.digikey.com/product-detail/ ... ND/1929225) works with the ESP32 as a replacement for the 4mb flash? I did try it and it was able to flash it, at least no error was reported, including the verify ...
by rsimpsonbusa
Tue May 26, 2020 3:33 pm
Forum: Hardware
Topic: 16MB Flash Winbond 133mhz not working
Replies: 1
Views: 301

Re: 16MB Flash Winbond 133mhz not working

Hi. To be more specific, the console output is rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT) configsip: 0, SPIWP:0xee clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00 mode:DIO, clock div:0 load:0x3fff0018,len:4 load:0x3fff001c,len:1260 load:0x40078000,len:13372 ho 0 t...
by rsimpsonbusa
Tue May 26, 2020 3:27 am
Forum: Hardware
Topic: 16MB Flash Winbond 133mhz not working
Replies: 1
Views: 301

16MB Flash Winbond 133mhz not working

Hi everybody. Hope all well at home and family. Does anybody know if a winbond W25Q16VSSIG (https://www.digikey.com/product-detail/en/winbond-electronics/W25Q16VSSIG/W25Q16VSSIG-ND/1929225) works with the ESP32 as a replacement for the 4mb flash? I did try it and it was able to flash it, at least no...
by rsimpsonbusa
Mon May 18, 2020 2:21 am
Forum: ESP32 IDF
Topic: mqtt ssl example certificate error
Replies: 13
Views: 1056

Re: mqtt ssl example certificate error

The certificate is for mosquitto.com in the WEB. You seem to be in your LAN. That is, Common Name (CN) in the Certificate will say https://mosquitto.org and your LAN will say localhost or whatever (127.0.0.1). They dont match at all. You can make a self signed certificate but that will also give u a...
by rsimpsonbusa
Mon May 18, 2020 2:09 am
Forum: ESP32 IDF
Topic: Problem with converting arduino SPI into IDF
Replies: 12
Views: 1032

Re: Problem with converting arduino SPI into IDF

In spi_transaction_t t; memset(&t, 0, sizeof(t)); t.length=8*4; t.flags = SPI_TRANS_USE_RXDATA; t.user = (void*)1; try setting the t.rxlength to a specific number fo bits. If u want all 4 bytes of USE_RXDATA then set it to 32. Maybe this can help. I looks like u are confusing the transmission data l...
by rsimpsonbusa
Sat May 09, 2020 10:41 pm
Forum: ESP32 IDF
Topic: example of HTTP server in AP mode?
Replies: 14
Views: 7607

Re: example of HTTP server in AP mode?

Hi @marchingband. Instead of writing all the details of a real example, not just a Hello World or echo one, the code attached is a good example. It will serve html files, the icons associated it as well as the css file. Cache control is important to minimize the ESP32 effort (sendUtils routine show ...
by rsimpsonbusa
Sat May 09, 2020 6:13 pm
Forum: ESP32 IDF
Topic: HTTP_Server: Error accepting connections when polling webserver functions from JavaScript
Replies: 5
Views: 1478

Re: HTTP_Server: Error accepting connections when polling webserver functions from JavaScript

A question.

Are you connected to the ESP32 via the STA or the AP interface? If its the AP (let say the STA disabled) one cannot send a jquery since it can not download the jquery lib to the browser unless in a desktop (LAN inteface).

Thanks

RSN

Go to advanced search