Search found 295 matches

by Ritesh
Thu Aug 17, 2017 5:44 pm
Forum: ESP32 SDK
Topic: SPIFFS open file fails in multitask system after few numbers of operations
Replies: 7
Views: 265

Re: SPIFFS open file fails in multitask system after few numbers of operations

Hi Loboris

I have checked your updated SPIFFS library from GitHub and tested basic and overnight test cases which works fine without any issue.

So, Thanks for providing update for that.
by Ritesh
Sun Aug 13, 2017 6:16 pm
Forum: ESP32 SDK
Topic: UART1 writes only "A"
Replies: 2
Views: 133

Re: UART1 writes only "A"

Hi, I have ESP32 from WeMos. Using uart0 for DEBUG thourgh USB. I configured uart1 to GPIO4(RX), GPIO2(tx). Plugged uart1 to USB serial converter. Both uarts running at 115200bps. Uart1 should work as communication betweern AI Thinker A7 (GSM module). I'm basicly trying to write "AT\r". W...
by Ritesh
Sun Aug 13, 2017 5:23 pm
Forum: ESP32 SDK
Topic: Issue with compiler or loading
Replies: 2
Views: 107

Re: Issue with compiler or loading

Hi Espressif, I have been often coming up with an issue where I make as simple code change , make and flash , and the change does not seem to be present in the active code. There are no build errors or warnings or anything. Even if I then do a clean, make and flash , it still does not work. I have ...
by Ritesh
Sun Aug 13, 2017 4:10 pm
Forum: ESP32 SDK
Topic: SPIFFS open file fails in multitask system after few numbers of operations
Replies: 7
Views: 265

Re: SPIFFS open file fails in multitask system after few numbers of operations

Hi Loboris, Thanks for quick update I will check it with example on Monday Morning and will update to you that it is working or not. Did you check with multiple tasks with multiple files in long stress test on your updated SPIFFS repository? We are getting problem in stress test like 1 to 2 hours te...
by Ritesh
Sat Aug 12, 2017 1:23 pm
Forum: ESP32 SDK
Topic: SPIFFS open file fails in multitask system after few numbers of operations
Replies: 7
Views: 265

Re: SPIFFS open file fails in multitask system after few numbers of operations

Hi Loboris,

Would you please check above issue and provide your valuable comments we we are facing this issue since last few days?

Let me know if you need any more details or any further details regarding this issue which we are facing this issue into ESP32.
by Ritesh
Sat Aug 12, 2017 1:21 pm
Forum: ESP32 SDK
Topic: Need sample code for ILI9488 LCD on SPI Interface
Replies: 68
Views: 4697

Re: Need sample code for ILI9488 LCD on SPI Interface

Hi Loboris, We have already posted one issue regarding ESP32 SPIFFS Flash File System in which we are facing some issue when we run some files related codes into overnight test. https://www.esp32.com/viewtopic.php?f=13&t=2498 So, Would you please check that issue and provide your comment as we a...
by Ritesh
Wed Aug 09, 2017 3:56 am
Forum: ESP32 SDK
Topic: Need API support to provide micro seconds delay
Replies: 9
Views: 546

Re: Need API support to provide micro seconds delay

Hi. Did you manage to get it work? In Nodemcu for esp32 (currently in development stage) they implement OneWire interface for esp32 using RMT. I plan to use it for DS18B20 since I don't like the idea of using delays for communication protocols. NodeMCU OneWire implementation for esp32 - https://git...
by Ritesh
Tue Jul 11, 2017 4:24 pm
Forum: ESP32 SDK
Topic: Getting extra byte 0xFF while configuring UART
Replies: 12
Views: 1007

Re: Getting extra byte 0xFF while configuring UART

Hi,

Please let me know if anyone has faced this type of issue while configuring UART with which another any module is connected over UART.

I have tried to look definition of "gpio_matrix_out(tx_io_num, tx_sig, 0, 0);" but not found it.
by Ritesh
Tue Jul 11, 2017 1:43 pm
Forum: ESP32 SDK
Topic: Getting extra byte 0xFF while configuring UART
Replies: 12
Views: 1007

Re: Getting extra byte 0xFF while configuring UART

Hi, Also the issue i am getting is random means sometimes I am getting garbage 0xFF as first byte randomly. So, The issue is in GPIO Matrix Output configurations which might cause this type of issue. I have tried it with PULLUP and PULLDOWN configurations for that TX PIN but still issue remains same...
by Ritesh
Tue Jul 11, 2017 12:48 pm
Forum: ESP32 SDK
Topic: Getting extra byte 0xFF while configuring UART
Replies: 12
Views: 1007

Re: Getting extra byte 0xFF while configuring UART

Hi, Sorry for late post. We have tried with uart_flush(uart_num) solution but it creates problem while re-configuring UART in existing running system like getting all bytes as garbage data while sending proper data. So, It means that solution is not proper to consider for actual product. Again, I ha...

Go to advanced search