Search found 92 matches

by michprev
Fri Apr 05, 2019 6:38 pm
Forum: General Discussion
Topic: RTOS running on one core only
Replies: 24
Views: 2543

Re: RTOS running on one core only

See viewtopic.php?f=12&t=422. Both interrupt handler and FreeRTOS adds some delay. I would suggest using one of high priority interrupts (which can not be serviced in C) but you need to understand Xtensa architecture very well.
by michprev
Fri Apr 05, 2019 5:00 pm
Forum: General Discussion
Topic: RTOS running on one core only
Replies: 24
Views: 2543

Re: RTOS running on one core only

Running the second core without FreeRTOS is not very easy. Basically you need to follow call_start_cpu0() function and do almost everything that is done in #if !CONFIG_FREERTOS_UNICORE directives. You should know that: you will need to care about 3.10 sillicon bug you will not be able to use newlib ...
by michprev
Sat Feb 23, 2019 2:07 pm
Forum: Report Bugs
Topic: UDP Broadcast Performance is Worse in AP mode than STA Mode
Replies: 1
Views: 685

Re: UDP Broadcast Performance is Worse in AP mode than STA Mode

I am experiencing similar issue viewtopic.php?f=2&t=9322. I have not solved it yet but it seems that ESP always sends all data but they are blocked / dropped / whatever by system. You should try to connect more listening devices at the same time.
by michprev
Tue Feb 19, 2019 12:11 pm
Forum: General Discussion
Topic: datagram loss reason
Replies: 0
Views: 302

datagram loss reason

Hi, I know that UDP does not guarantee that data will be ever delivered. I am broadcasting 21 bytes long datagram every 1 second but sometimes it is not delivered - usually 1 or 2 datagrams are missing in a row. I am attaching wireshark log. Even more interesting is that I don't see any packet drop ...
by michprev
Fri Jan 11, 2019 7:12 pm
Forum: General Discussion
Topic: [SPI] how to stop using DMA
Replies: 8
Views: 1449

Re: [SPI] how to stop using DMA

Unfortunately I have written driver only for SPI master. As I am no longer working with ESP32 I do not plan to extend it also for SPI slave. There is a hardware bug in SPI DMA https://github.com/espressif/esp-idf/blob/72b3c6d6b8ae3da076680c431ec239a0ff4c23d0/components/driver/spi_common.c#L382-L438 ...
by michprev
Thu Dec 13, 2018 5:07 pm
Forum: General Discussion
Topic: [SPI] how to stop using DMA
Replies: 8
Views: 1449

Re: [SPI] how to stop using DMA

Found the issue, it is not even DMA related. If you set SPI_FASTRD_MODE to 0 and SPI_FREAD_QIO to 1 hardware will still perform QIO transmission. It has been fixed in TRM from 07/12/2018. Also, out of curiosity, is there a reason you're writing your own driver, foregoing the one in esp-idf? In the p...
by michprev
Wed Dec 12, 2018 10:37 pm
Forum: General Discussion
Topic: [SPI] how to stop using DMA
Replies: 8
Views: 1449

[SPI] how to stop using DMA

Hi, let's say that I want to use SPI with DMA channel and then without DMA channel. To use DMA I set channel in DPORT_SPI_DMA_CHAN_SEL_REG register. I set DPORT_SPI3_DMA_CHAN_SEL to either 1 or 2. SPI DMA transmission is successful but how to stop using DMA now? When I set DPORT_SPI3_DMA_CHAN_SEL to...
by michprev
Sun Nov 25, 2018 11:11 am
Forum: ESP32 IDF
Topic: SPI1 flash driver and DMA
Replies: 1
Views: 420

SPI1 flash driver and DMA

Can someone confirm that spi flash driver running on SPI1 never uses DMA?

Thank you.
by michprev
Sun Nov 25, 2018 8:43 am
Forum: Documentation
Topic: Documentation Requests/Feedback
Replies: 63
Views: 48467

Re: Document Requests

https://docs.espressif.com/projects/esp ... own-issues
Half duplex mode is not compatible with DMA when both writing and reading phases exist.
What does it mean exactly? When SPI_DOUTDIN in SPI_USER_REG is set to zero this issue occurs?
by michprev
Sat Nov 24, 2018 9:47 pm
Forum: General Discussion
Topic: Gripes on ESP32/ESP-IDF
Replies: 44
Views: 9092

Re: Gripes on ESP32/ESP-IDF

https://github.com/espressif/esp-idf/issues/2738 Now take a look at this issue. It is present in v3.1 release even in master branch at the moment. Because of that assert SPI driver fails whenever trying to use it in DIO/QIO mode. Does it seem like a minor issue to you? This bug exists there over th...

Go to advanced search