Search found 31 matches

by mpulis
Thu May 21, 2020 10:45 am
Forum: ESP32 MDF
Topic: ESP IDF Version Support with MDF
Replies: 4
Views: 3414

Re: ESP IDF Version Support with MDF

Same here. Is there any timeline for this?
by mpulis
Fri Mar 27, 2020 8:37 am
Forum: ESP32 MDF
Topic: ESP IDF Version Support with MDF
Replies: 4
Views: 3414

Re: ESP IDF Version Support with MDF

Hi,

Thanks for the reply!
by mpulis
Wed Mar 25, 2020 9:37 am
Forum: ESP32 MDF
Topic: ESP IDF Version Support with MDF
Replies: 4
Views: 3414

ESP IDF Version Support with MDF

Hi all, I've tried to run the last stable release version of the MDF (v1.0) alongside the last stable release version of the IDF (v4.1) to no avail. On checking which IDF version the MDF repository was using, I've discovered that it's v3.2. Can I get MDF working with the latest IDF release? Is it ju...
by mpulis
Tue Mar 24, 2020 4:47 pm
Forum: ESP32 IDF
Topic: ESP-MESH: Each node needs knowledge of the router ...
Replies: 7
Views: 4596

Re: ESP-MESH: Each node needs knowledge of the router ...

Hi,

By any chance is there any progress on the 'non-router' mesh network?
by mpulis
Tue Dec 03, 2019 8:56 am
Forum: General Discussion
Topic: SPI Slave - Missing data during the first few seconds after initialization
Replies: 3
Views: 461

Re: SPI Slave - Missing data during the first few seconds after initialization

If the problem was coming from those tasks, wouldn't the problem persist beyond those 34 seconds? I've run tests for an hour with the same results. It does seem to be something to do with initialization. Could it be that there is some conflict initially between the SDMMC host and the VSPI peripheral...
by mpulis
Mon Dec 02, 2019 11:06 am
Forum: General Discussion
Topic: SPI Slave - Missing data during the first few seconds after initialization
Replies: 3
Views: 461

SPI Slave - Missing data during the first few seconds after initialization

Hi all! I've setup a program which reads incoming data over the SPI Slave Interface and saves all the received data to a file on a connected SD card once the buffer which is being written to is full. The received data is in the form of an incrementing counter. The problem which I'm observing is that...
by mpulis
Mon Oct 14, 2019 5:41 am
Forum: General Discussion
Topic: SPI Slave Issue - MOSI data being echoed onto MISO
Replies: 1
Views: 482

Re: SPI Slave Issue - MOSI data being echoed onto MISO

Any suggestions on this? Or perhaps is further clarification of the issue needed?
by mpulis
Fri Oct 11, 2019 10:50 am
Forum: General Discussion
Topic: SPI Slave Issue - MOSI data being echoed onto MISO
Replies: 1
Views: 482

SPI Slave Issue - MOSI data being echoed onto MISO

Hi all, I've setup an ESP32 as an SPI slave communicating with another microcontroller along with 3 other SPI slaves. The master is communicating at a speed of 1MHz. The problem is that the data on the MOSI line was being echoed on the MISO line, even with the tx_buffer of the SPI transaction struct...
by mpulis
Fri Jul 26, 2019 7:12 am
Forum: General Discussion
Topic: Issues with SPI Slave
Replies: 1
Views: 506

Re: Issues with SPI Slave

Update: I've managed to get the SPI transmit working! I changed the configuration CONFIG_SPI_SLAVE_IN_IRAM to enabled. From my understanding this places the transmit function (which I would assume the function responsible for handling any data to be sent over MISO if the tx_buffer of the transaction...
by mpulis
Fri Jul 26, 2019 6:04 am
Forum: General Discussion
Topic: Issues with SPI Slave
Replies: 1
Views: 506

Issues with SPI Slave

Hi all, I'm currently working with the SPI Slave peripheral but am running into 2 issues. 1. I'm setting up a transaction using spi_slave_transmit() with the ticks_to_wait argument set to portMAX_DELAY. I'd expect the function to block there until the Master initiates a transaction, but the task con...

Go to advanced search