Search found 19 matches

by tharunjoy
Wed Feb 19, 2020 9:04 am
Forum: ESP-IDF
Topic: ESP_OTA: OTA image has invalid magic byte
Replies: 5
Views: 1531

Re: ESP_OTA: OTA image has invalid magic byte

Thank you guys..
I found the reason for this issue. Just like you guys told ESP is not able to automatically redirect the URL like a web browser. I just found the redirected URL and used that in the program, to successfully do an OTA update.
by tharunjoy
Tue Feb 18, 2020 12:52 pm
Forum: ESP-IDF
Topic: ESP_OTA: OTA image has invalid magic byte
Replies: 5
Views: 1531

Re: ESP_OTA: OTA image has invalid magic byte

I download image using curl and tried flashing through serial and got the same error. E (141) esp_image: image at 0x40000 has invalid magic byte W (147) esp_image: image at 0x40000 has invalid SPI mode 116 W (153) esp_image: image at 0x40000 has invalid SPI size 6 E (159) boot: Factory app partition...
by tharunjoy
Mon Feb 17, 2020 11:38 am
Forum: ESP-IDF
Topic: ESP_OTA: OTA image has invalid magic byte
Replies: 5
Views: 1531

ESP_OTA: OTA image has invalid magic byte

Hi, I am using ESP IDF 3.3v. I am trying to implement OTA update. I ran an openssl server locally and I was able to do OTA update smoothly. Then I tried deploying the same application firmware in onedrive, google drive and even in dropbox where I am getting some error as show below. I (641674) esp_h...
by tharunjoy
Thu Nov 21, 2019 7:32 am
Forum: ESP-IDF
Topic: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013
Replies: 5
Views: 1745

Re: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013

The issue was with the server device as per the reason=0x0013:: ESP_GATT_CONN_TERMINATE_PEER_USER
Reconfigured the BLE_GATT_Server device and the issue was resolved.
by tharunjoy
Thu Nov 21, 2019 6:30 am
Forum: ESP-IDF
Topic: BLE Client autoconnection or reconnection
Replies: 0
Views: 614

BLE Client autoconnection or reconnection

Hi all, I am working on ble GATT client. Can anyone explain to me more about BLE reconnection and auto-connection? I have seen esp_ble_gattc_open function, esp_ble_gattc_open(gl_profile_tab[PROFILE].gattc_if, scan_result->scan_rst.bda, scan_result->scan_rst.ble_addr_type, true); were the documentati...
by tharunjoy
Thu Nov 07, 2019 5:58 am
Forum: General Discussion
Topic: bluetooth client error message
Replies: 2
Views: 2105

Re: bluetooth client error message

Hi,
I am getting same error.
Did you resolve this?
by tharunjoy
Mon Sep 16, 2019 6:22 am
Forum: ESP-IDF
Topic: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013
Replies: 5
Views: 1745

Re: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013

Hi @chegewara , 'ESP IDF is getting disconnected when the peripheral device stops advertising'. I found this based on one of my analyses on ble server(remote) disconnection from ble client(esp32). Before I was worried about my server configuration, so in-order to replicate another ble server I downl...
by tharunjoy
Mon Sep 09, 2019 9:59 am
Forum: ESP-IDF
Topic: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013
Replies: 5
Views: 1745

Re: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013

Hi,
I have to add one more analysis to this.

'ESP IDF is getting disconnected when the peripheral device stops advertising'.

How to stabilize the connection even after the advertisement stops?
by tharunjoy
Mon Sep 09, 2019 12:40 am
Forum: ESP-IDF
Topic: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013
Replies: 5
Views: 1745

Re: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013

Hi, I am adding more logs to this. Unhandled GAP event: 14 D (13167) BT_GATT: GATT ATT protocol channel with BDA: 000XXXXXXX16 is disconnected D (13167) BT_GATT: gatt_is_bda_in_the_srv_chg_clt_list :00-0b-20-07-05-16 D (13177) BT_GATT: gatt_cleanup_upon_disc D (13177) BT_GATT: found p_tcb D (13177) ...
by tharunjoy
Fri Sep 06, 2019 7:42 am
Forum: ESP-IDF
Topic: BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013
Replies: 5
Views: 1745

BLE disconnection: cif=3 connected=0 conn_id=3 reason=0x0013

Hi, I am trying to build an ESP32 as a BLE GATT client to receive a connection from BLE remote(ATB110x). While trying to connect to the device I am immediately disconnecting from the server. W (23898) BT_APPL: bta_gattc_conn_cback() - cif=4 connected=0 conn_id=4 reason=0x0013 I (23908) GATT_CLIENT :...

Go to advanced search