Search found 12 matches

by GvTardy
Sun Sep 01, 2019 10:18 am
Forum: ESP32 IDF
Topic: Windows Powershell OTA - how to?
Replies: 3
Views: 269

Re: Windows Powershell OTA - how to?

Hi, I verified Chegewara"s link and got it working: curl 192.168.1.1:8032 --data-binary @- < build/ota.bin running the above command from the project root, pointing to the binary, IP set to the one of the ESP32, port according to the defined one works in the command <cmd> windows. If you like to run...
by GvTardy
Mon Aug 26, 2019 8:13 pm
Forum: ESP32 IDF
Topic: Windows Powershell OTA - how to?
Replies: 3
Views: 269

Re: Windows Powershell OTA - how to?

Hi Chegewara,

thank you for your reply. Looks exactly like I was looking for.

I will try this soon and leave a comment thereafter to complete this thread.

Greetings
Georg
by GvTardy
Sun Aug 25, 2019 1:05 pm
Forum: ESP32 IDF
Topic: Windows Powershell OTA - how to?
Replies: 3
Views: 269

Windows Powershell OTA - how to?

Hi, I have windows 10 and VSC installed. Using the current toolchain (installed mid of August) I compiled an OTA example I wrote. Previously I used BASH, so I could update over the air: curl ${ESP32_IP}:8032 --data-binary @- < buld/$(PROJECT_NAME).bin Now I have trouble to figure out how I can run a...
by GvTardy
Sat Mar 16, 2019 1:40 pm
Forum: ESP32 IDF
Topic: UDP client does not start to send in AP mode
Replies: 4
Views: 1468

Re: UDP client does not start to send in AP mode

Firewall !!!

I missed a specific setting for public, non protected networks...

Alas, a stupid way to burn so much time, but at least it's working now.

Greetings
Georg
by GvTardy
Sat Mar 16, 2019 12:22 pm
Forum: ESP32 IDF
Topic: UDP client does not start to send in AP mode
Replies: 4
Views: 1468

Re: UDP client does not start to send in AP mode

Hello everyone, I installed Wireshark to monitor the UDP traffic. Interesting finding: The ESP32 does start sending messages as soon as the station (my Laptop) has connected. BUT: non of my terminal programs starts displaying these messages before I send a line to the ESP32 (Hercules, YAT, script co...
by GvTardy
Thu Mar 14, 2019 9:03 pm
Forum: ESP32 IDF
Topic: UDP client does not start to send in AP mode
Replies: 4
Views: 1468

Re: UDP client does not start to send in AP mode

Dear all, unfortunately I have to revise my last nights reply. If I give the ESP32 a full power cycle (not just make monitor), the connection to the terminal will not work prior to sending a message (e.q "1") to the ESP. I corrected/cleaned the code a bit and post it again here. Does anyone have a c...
by GvTardy
Wed Mar 13, 2019 10:23 pm
Forum: ESP32 IDF
Topic: UDP client does not start to send in AP mode
Replies: 4
Views: 1468

Re: UDP client does not start to send in AP mode

Hi to everybody reading,

I fiddled more with my code and got is solved tonight, but I do not understand why.

I will post the complete code tomorrow with comments. It is getting late tonight, so my apologies for not doing so right away.

Very kind regards
Georg
by GvTardy
Wed Mar 13, 2019 8:21 pm
Forum: ESP32 IDF
Topic: UDP client does not start to send in AP mode
Replies: 4
Views: 1468

UDP client does not start to send in AP mode

Hi to everybody, I have a problem with a UDP client setup: I start a DHCP server, then WIFI in AP mode. Once this is done I start a UDP client in a task. This works all without problems, I can connect to it with my computer, receive an address and start sending UDP messages. The bad thing is: I do n...
by GvTardy
Sat Jan 05, 2019 11:41 am
Forum: ESP32 IDF
Topic: WSL Ubuntu & Silabs CP210x => COM Port Problem
Replies: 4
Views: 1346

Re: WSL Ubuntu & Silabs CP210x => COM Port Problem

Hello Chris, thank you for your answer. I totally agree: if you are serious about it, go native! As I am hobbyist and have all my other computer programs windows based, installing a native Linux is not an option. I tried Msys32 before, this gave the impression of being slow, though I failed to time ...
by GvTardy
Fri Jan 04, 2019 1:15 pm
Forum: ESP32 IDF
Topic: WSL Ubuntu & Silabs CP210x => COM Port Problem
Replies: 4
Views: 1346

Re: WSL Ubuntu & Silabs CP210x => COM Port Problem

Hi,

I solved this problem:

finding that the problem was caused by windows, I downloaded another driver.

The one on the SILICON LABS web page does not seem to work.

I now use the one provided by Pololu, which works fine with Windows and WSL Ubuntu.

Sorry for bother you,
hope I helps others.

GvTT

Go to advanced search