Search found 6 matches

by nickhaman
Mon Oct 28, 2019 4:46 pm
Forum: ESP-IDF
Topic: Image signing
Replies: 4
Views: 1370

Re: Image signing

I found this link that says that it is incompatible with CMAKE, so I gave up:
https://esp32.com/viewtopic.php?t=9640
by nickhaman
Sat Oct 19, 2019 8:30 pm
Forum: ESP-IDF
Topic: Image signing
Replies: 4
Views: 1370

Image signing

I followed the instructions in the esp-idf for turning on code signing. After generating the keys, I get the following linking error: ------ Build started: Project: app-template, Configuration: Debug VisualGDB ------ VisualGDB: Run "C:\PROGRA~2\Sysprogs\VISUAL~1/ninja.exe " in directory "D:\VS2\Embe...
by nickhaman
Wed Jun 05, 2019 7:10 pm
Forum: ESP-IDF
Topic: Component.mk executing windows command
Replies: 0
Views: 531

Component.mk executing windows command

What is the correct format to execute an external command in the component.mk file?

I would like to call Nanopb to recompile the protobuf files before compilation. I've tried:

cmd //C /NanoPb/generator-bin/protoc voltage_logging.proto --nanopb_out=.

but I get a missing separator error.
by nickhaman
Sat May 18, 2019 12:11 am
Forum: Hardware
Topic: EPS32-WROOM-32D JTAG
Replies: 1
Views: 887

EPS32-WROOM-32D JTAG

I am having an issue with a custom board and this module using JTAG. I am connecting to the JTAG pins on the custom board using the JTAG port on the ESP32-WROVER kit with the jumpers removed. Openocd gives me the following error: Error: JTAG scan chain interrogation failed: all ones Upon investigati...
by nickhaman
Thu Apr 18, 2019 10:11 pm
Forum: General Discussion
Topic: ESP32-WROVER-KIT Eclipse JTAG programming
Replies: 3
Views: 1620

Re: ESP32-WROVER-KIT Eclipse JTAG programming

That did the trick, thank you!
by nickhaman
Sat Mar 09, 2019 11:09 pm
Forum: General Discussion
Topic: ESP32-WROVER-KIT Eclipse JTAG programming
Replies: 3
Views: 1620

ESP32-WROVER-KIT Eclipse JTAG programming

I am having a problem programming and debugging the ESP32 over JTAG with Eclipse. When I try programming over JTAG, I get verify errors in openocd and debugging fails. If I program using the Build Target and the flash tool, programming succeeds and I can connect to openocd and debug normally. This w...

Go to advanced search