Search found 208 matches

by f.h-f.s.
Tue Oct 31, 2017 12:36 pm
Forum: ESP32 IDF
Topic: Unable to read characteristics since new API
Replies: 1
Views: 887

Unable to read characteristics since new API

Since the new GATTC API I am unable to read the characteristics. The same flow is used. Scan for advertising devices and gattc_open the proper device. A GATTC_CONNECT event is followed by a GATTC_OPEN event. A ESP_GAP_BLE_SEC_REQ_EVT is raised and we respond with true. The devices successfully pair ...
by f.h-f.s.
Sun Oct 22, 2017 10:39 am
Forum: General Discussion
Topic: Including mbedtls - undefined references
Replies: 1
Views: 695

Re: Including mbedtls - undefined references

You should not have to copy the mbedtls folder to your own components folder. What happens when you try to build the https example(it uses the mbedtls component)? https://github.com/espressif/esp-idf/tree/master/examples/protocols/https_request If you have set up everything correctly you should be a...
by f.h-f.s.
Wed Oct 18, 2017 8:52 am
Forum: ESP32 IDF
Topic: vfs_fat_spiflash: esp_vfs_fat_register failed 0x(101)
Replies: 0
Views: 625

vfs_fat_spiflash: esp_vfs_fat_register failed 0x(101)

Hi all, I added the wear-level FAT filesystem to my project. Had low memory at the startup so I added a delay before I started the vfs and it works. Then I wanted to move the startup of vfs to a callback I get when my connections are set up. When I start vfs at that point, esp_vfs_fat_register fails...
by f.h-f.s.
Fri Oct 13, 2017 10:33 am
Forum: ESP32 IDF
Topic: gattc open issue
Replies: 10
Views: 5721

Re: gattc open issue

Disconnect Reason 0x003E meant BLE_HCI_CONN_FAILED_TO_BE_ESTABLISHED https://devzone.nordicsemi.com/question/37528/connection-is-disconnected-automatically/ https://devzone.nordicsemi.com/question/41570/unknown-hci-errors/ Some more information, reasons for this error. There is a closed issue with ...
by f.h-f.s.
Wed Oct 11, 2017 7:48 am
Forum: ESP32 IDF
Topic: LoadProhibited on fprintf in function set by esp_log_set_vprintf
Replies: 2
Views: 1056

Re: LoadProhibited on fprintf in function set by esp_log_set_vprintf

Wow ok, yes. distinct difference that I did not notice =/ Thanks.
by f.h-f.s.
Mon Oct 09, 2017 2:19 pm
Forum: ESP32 IDF
Topic: LoadProhibited on fprintf in function set by esp_log_set_vprintf
Replies: 2
Views: 1056

LoadProhibited on fprintf in function set by esp_log_set_vprintf

I am trying to split ESP logging to both the UART and a File on Wear-level, however I am getting a "LoadProhibited" when I try to call fprintf on the FILE* in the function set by esp_log_set_vprintf. I don't see any hints in the backtrace on what I am doing wrong. fprintf works perfectly when I am n...
by f.h-f.s.
Mon Oct 09, 2017 8:23 am
Forum: General Discussion
Topic: Stuck in loop (I think)
Replies: 1
Views: 985

Re: Stuck in loop (I think)

if you open the COM port with Putty, idf-monitor or any other serial terminal you can check if your esp32 is in download mode. When you hold the boot button and power button, then release the power button you should see the following(or something like this). ets Jun 8 2016 00:22:57 rst:0x1 (POWERON_...
by f.h-f.s.
Thu Oct 05, 2017 10:01 am
Forum: ESP32 IDF
Topic: ESP-IDF component with Arduino
Replies: 1
Views: 1788

Re: ESP-IDF component with Arduino

Try compiling with your AzureIoTHub component disabled. (rename component.mk to component.mk.disabledorsmthn)
D:/github/esp/esp-idf/components/AzureIoTHub/include/pgmspace.h:41:0: note: this is the location of the previous definition
#define F(s) (s)
^
by f.h-f.s.
Thu Oct 05, 2017 9:56 am
Forum: General Discussion
Topic: Retreiving UUIDs of iBeacons
Replies: 2
Views: 1254

Re: Retreiving UUIDs of iBeacons

You are getting the MAC addresses in a GAP callback case ESP_GAP_SEARCH_INQ_RES_EVT right? And have access to the variable "esp_ble_gap_cb_param_t result". The inquiry "result" contains "scan_rst"(See esp_gap_ble_api.h#490), which contains the advertisment "ble_adv". You can resolve that advertiseme...
by f.h-f.s.
Fri Sep 22, 2017 10:21 am
Forum: General Discussion
Topic: Did I brick it?
Replies: 4
Views: 2188

Re: Did I brick it?

Could it be the cable, or the usb uart chip on the dev board?
You can always try to power the ESP32 directly and attach a serial ttl to the rx/tx to see if the chip still works.

Go to advanced search