Search found 606 matches

by fly135
Tue Feb 13, 2018 8:42 pm
Forum: Report Bugs
Topic: BLE/GATT doesn't send response error
Replies: 4
Views: 2262

Re: BLE/GATT doesn't send response error

More info... I ran the GATT_SERVER and GATT_CLIENT on two ESP32 boards and they are communicating. The server didn't hang and stop responding when it recv'd the Read by Group GETT include declaration. It also responded with the Attribute not found response. That's the response that didn't go out as ...
by fly135
Tue Feb 13, 2018 5:45 pm
Forum: Report Bugs
Topic: BLE/GATT doesn't send response error
Replies: 4
Views: 2262

Re: BLE/GATT doesn't send response error

More notes on this. This disconnect doesn't occur immediately. It occurs after about 7 sec, which I believe is the connection timeout. I've included a pic of a wireshark ble sniff. The highlighted line is the last packet send by the server to the client. That explains the connection timeout as the c...
by fly135
Mon Feb 12, 2018 8:33 pm
Forum: General Discussion
Topic: Struggling with creating a BLE server.
Replies: 2
Views: 1112

Struggling with creating a BLE server.

I've been trying to get the ESP32 to work as a BLE server with little luck. I just posted what appears to be a bug in the bug reporting section of the forum. Nothing I've tried so far has worked to connect with any app on my Android and I've found what appears to be suspicious behavior. I'v found th...
by fly135
Mon Feb 12, 2018 8:25 pm
Forum: Report Bugs
Topic: BLE/GATT doesn't send response error
Replies: 4
Views: 2262

BLE/GATT doesn't send response error

Can't seem to get my BLE app (ex. ble_spp_server) to send response errors. An "attribute not found" error response should be sent in response to a Read by Type request on handles 1-5 for GATT Include Declaration (0x2803). There are 5 bytes that should be sent. 01 - Error Response 08 - Op code in err...
by fly135
Sat Jan 13, 2018 11:14 pm
Forum: General Discussion
Topic: xTaskCreate -> Crash
Replies: 7
Views: 3924

Re: xTaskCreate -> Crash

I totally was bit by these problems today. I found that adding a printf used up about 2K of stack. And I was crashing on exiting the task until I read the doc that WiFi referenced.
by fly135
Wed Jan 10, 2018 7:35 pm
Forum: ESP32 IDF
Topic: [Video]: Bluetooth BLE and C++ classes
Replies: 62
Views: 29329

Re: [Video]: Bluetooth BLE and C++ classes

Just tried to duplicate this based on your youtube video. Looks like there are significant changes that have made it more complicated than the video. Thanks for all videos and contributions.

John

Go to advanced search