Search found 15 matches

by DanCurram
Wed Feb 27, 2019 3:56 pm
Forum: General Discussion
Topic: Do I need to clear bonded devices?
Replies: 10
Views: 5367

Re: Do I need to clear bonded devices?

neither of these calls work correctly I have tried both calls esp_bt_gap_remove_bond_device()` is used to remove the classic bluetooth encryption key from flash. esp_ble_remove_bond_device()` is used to remove the BLE encryption key from flash. When the esp32 device is reset the previous pairings ar...
by DanCurram
Wed Nov 28, 2018 5:12 pm
Forum: General Discussion
Topic: Do I need to clear bonded devices?
Replies: 10
Views: 5367

Re: Do I need to clear bonded devices?

Weijian-Espressif Thanks for your clarification 15 is far more than I need. But in my case I deliberately want to delete all bonding's at a time of my choosing. So is this a clarification that the function esp_bt_gap_remove_bond_device() and NVS data associated with bonding is suffering from "Uninte...
by DanCurram
Mon Nov 26, 2018 4:32 pm
Forum: General Discussion
Topic: Do I need to clear bonded devices?
Replies: 10
Views: 5367

Re: Do I need to clear bonded devices?

Thanks for your response To help put this more in context of how I am using the commands. I have written code in C to make the esp32 behave similar to a Bluegiga wt12 modules ASCII commands. The Esp32 module is run as a classic BT SPP device. There is a WT12 command eg "SET PAIR *\r\n" that is suppo...
by DanCurram
Thu Nov 22, 2018 3:23 pm
Forum: General Discussion
Topic: Do I need to clear bonded devices?
Replies: 10
Views: 5367

Re: Do I need to clear bonded devices?

Folks anyone have any pointers on an issue to do with removing bonded devices I use the esp_bt_gap_remove_bond_device call and it returns ESP_OK for each esp_bd_addr_t but if I reset the device the bonds are still there The bonds can be removed If I do the above and then try connect a previous bt de...
by DanCurram
Tue Jun 12, 2018 2:18 pm
Forum: Sample Code
Topic: BLE_SPP_SERVER
Replies: 2
Views: 2908

Re: BLE_SPP_SERVER

I had a similar issue until I spotted the ascii values in hex in other data used to setup the device.
the name is inn the spp_adv_data[] array. eg look for ascii values in hex to spot it and the size of the string.

Go to advanced search