Search found 51 matches

by Helen L
Fri Mar 29, 2019 9:01 am
Forum: General Discussion
Topic: ESP32 AT command BT CLASSIC
Replies: 2
Views: 860

Re: ESP32 AT command BT CLASSIC

I also use the BT classic, but never met data loss. Maybe you can connect the UART CTS, RTS, enable the UART flow control and try it again. To see if it is the UART that lost data.
by Helen L
Sun Mar 24, 2019 7:03 am
Forum: General Discussion
Topic: ESP32 WROVER not responding for AT commands.
Replies: 4
Views: 1746

Re: ESP32 WROVER not responding for AT commands.

Have you tried the ESP Flash Download Tool? Maybe you can erase the entire flash firstly and then download the firmware into it.

After downloading the ESP32_AT Bin, in the "factory" folder, there is an AT bin for ESP32-WROVER, you can download it into the address 0. AT baud rate is 115200.
by Helen L
Mon Mar 11, 2019 6:04 am
Forum: ESP IoT Solution
Topic: AT commands for BLE throws error
Replies: 5
Views: 1863

Re: AT commands for BLE throws error

There are two ways to upgrade the AT firmware:
1. FOTA: Connect the ESP32 to a router to access the internet, call command "AT+CIUPDATE" for upgrading.
2. Flashing the board: Download one of the bins in the ESP32_AT/factory directory to address 0x0.
by Helen L
Fri Mar 08, 2019 7:13 am
Forum: ESP32 IDF
Topic: esp-at v1.2 with SparkFun ESP32 Thing
Replies: 1
Views: 716

Re: esp-at v1.2 with SparkFun ESP32 Thing

AT command is via GPIO16, GPIO17 by default. Could it due to the wrong pins?
by Helen L
Fri Mar 08, 2019 7:11 am
Forum: ESP32 IDF
Topic: esp32-at wifi access point web server very slow
Replies: 3
Views: 1183

Re: esp32-at wifi access point web server very slow

It is hard to tell. Maybe due to the bad network? It needs the captured Wi-Fi packets for further analyzing. Wireshark or omnipeek, both are fine.
by Helen L
Tue Mar 05, 2019 6:32 am
Forum: ESP IoT Solution
Topic: Interface other than AT command through UART IO
Replies: 2
Views: 1141

Re: Interface other than AT command through UART IO

Maybe you can follow the BLE example on GitHub to run the BLE AT commands.
by Helen L
Tue Mar 05, 2019 3:34 am
Forum: ESP IoT Solution
Topic: AT commands for BLE throws error
Replies: 5
Views: 1863

Re: AT commands for BLE throws error

In the ESP32_AT/factory is the combined bins for different ESP32 module. You can download one of them according to your actual module.
by Helen L
Tue Mar 05, 2019 2:11 am
Forum: ESP32 IDF
Topic: esp32-at wifi access point web server very slow
Replies: 3
Views: 1183

Re: esp32-at wifi access point web server very slow

Does it due to the bad network? Have you captured the WiFi packets for further analyzing?
by Helen L
Mon Mar 04, 2019 8:14 am
Forum: General Discussion
Topic: AT firmware Hostname error
Replies: 1
Views: 769

Re: AT firmware Hostname error

Could you list the AT commands you used?