ESP-IDF Eclipse Plugin v2.0.0 Release

ESP_Minatel
Posts: 182
Joined: Mon Jan 04, 2021 2:06 pm

ESP-IDF Eclipse Plugin v2.0.0 Release

Postby ESP_Minatel » Fri Mar 05, 2021 9:38 am

This is a major release to support Eclipse 2020-12, CDT 10.x, and CMake4Eclipse Parser update along with a good set of improvements and bug fixes to improve the plugin functionality.

It's highly recommended to use the Eclipse 2020-12 CDT Package with this release. If you are an existing user, while updating your Eclipse 2020-06(4.16) and Eclipse 2020-09(4.17) you will see an update error and the plugin will show you a path to update the Eclipse 2020-12(4.18). Please choose the Update my Installation to be compatible with the Items being installed option from the Install page to proceed with the installation.

Users who don't want to change the base Eclipse version still need to update the CDT 10.1.0 before installing the ESP-IDF Eclipse Plugin 2.0.0 release.


Full Release Notes

Who is online

Users browsing this forum: No registered users and 5 guests