ESP-WROOM-32 flash fail

Almador
Posts: 4
Joined: Thu Jan 12, 2017 6:21 pm

ESP-WROOM-32 flash fail

Postby Almador » Thu Jan 12, 2017 7:07 pm

Hi there,

I am trying for a few days to flash my ESP-WROOM-32 via FTDI and I do not know what I am doing wrong.
Please have a look at my "setup". I am grateful for any advice.

If I try to flash the DevKit-Board (on COM6) it works just fine. So the esp-idf shouldn't be the problem.

Image

http://www2.pic-upload.de/img/32475546/IMAG0712.jpg - Here is a picture of the breadboard.
I use an own-build breakout board and connect basically just 3V3, GNDs, EN, IO0, TX and RX. I also tried to pull IO12 down. No use.

Since I can monitor the ESP-WROOM-32 to see that it really goes to boot-mode, my FTDI seems to work.

Image

Now when I change COM6 to COM3 (FTDI) in "menuconfig" it looks like this:
(I disconnect the terminal before, of couse)

https://www.youtube.com/watch?v=AoPKetV ... e=youtu.be

I am pretty sure it is something quite simple, which I just do not thing about.

Kind Regards
Alex

ESP_Angus
Posts: 1267
Joined: Sun May 08, 2016 4:11 am

Re: ESP-WROOM-32 flash fail

Postby ESP_Angus » Fri Jan 13, 2017 5:07 am

Hi Alex,

The error at the end of your video indicates the stub returning result 0xc1 in response to a data packet, which in the esptool flasher source code is ESP_BAD_DATA_CHECKSUM. Implies that some of the data file got corrupted between being sent by the FTDI and received by the ESP32.

Does it fail at a different part of the flashing each time, or is it always at the end like in the video?

Usually this is either a signal integrity issue (noisy data lines, etc) or a power problem (ESP32 is browning out). Nothing looks immediately wrong to me in the photo you posted, though.

Angus

Almador
Posts: 4
Joined: Thu Jan 12, 2017 6:21 pm

Re: ESP-WROOM-32 flash fail

Postby Almador » Fri Jan 13, 2017 12:32 pm

It fails always at the end after 100% like in the video (guess during the checksum test).
Unfortunately the power supply is fine, that would be easy to solve.
But I had that idea as well and monitored the voltage while flashing. It remains between 3.29V and 3.31V.

I also pluged in the FTDI into the breadboard to avoid the wires in between, still the same.

WiFive
Posts: 2056
Joined: Tue Dec 01, 2015 7:35 am

Re: ESP-WROOM-32 flash fail

Postby WiFive » Sat Jan 14, 2017 8:16 pm

Is it always at 0x00084000?

Almador
Posts: 4
Joined: Thu Jan 12, 2017 6:21 pm

Re: ESP-WROOM-32 flash fail

Postby Almador » Sun Jan 15, 2017 1:18 pm

Yes, it's always at the end (after 100%). Although I think it is the next step which fails.
The module itself shouldn't be the problem, since I tried it with two "different" and got the same result.

Image

There must be something wrong with my setup, but I do really have none idea what is is :( .

Almador
Posts: 4
Joined: Thu Jan 12, 2017 6:21 pm

[SOLVED] - ESP-WROOM-32 flash fail

Postby Almador » Fri Jan 27, 2017 6:08 pm

I finally figured it out! Even though it does not make sense to me at all.
If I use a CP2104 as USB <-> UART instead of the FTDIs, it works fine.

I do not really understand why, because both operrate at 3.3V. Since I could use the FTDIs for monitoring and to flash other devices, the driver is fine as well... :?:

However, at least it works now! :lol:

Prasad
Posts: 25
Joined: Sun Jul 23, 2017 5:26 pm

Re: ESP-WROOM-32 flash fail

Postby Prasad » Thu Nov 08, 2018 12:40 pm

I had a similar sort of problem. mine was giving below error - It simply can't open the port. But apparently even i disconnected the Tx, Rx pins still this error throws just powering the ESP Wroom 32 from it. My guess is something wrong with the USB <> UART convertor power rail. It all worked once i changed the USB <> UART convertor to FTDI FT 232RL module. Previously i used PL2303 Chip. Just posting in a hope that this might help someone with a similar kind of problem.

Code: Select all

Prasads-MacBook-Pro-2:hello_world prasaddezoysa$ make flash
Toolchain path: /Users/prasaddezoysa/Documents/Projects/Electronics/Projects/ESP/xtensa-esp32-elf/bin/xtensa-esp32-elf-gcc
Toolchain version: crosstool-ng-1.22.0-80-g6c4433a
Compiler version: 5.2.0
Python requirements from /Users/prasaddezoysa/Documents/Projects/Electronics/Projects/ESP/esp-idf/requirements.txt are satisfied.
Flashing binaries to serial port /dev/tty.usbserial (app at offset 0x10000)...
esptool.py v2.6-beta1
Serial port /dev/tty.usbserial
Traceback (most recent call last):
  File "/Users/prasaddezoysa/Documents/Projects/Electronics/Projects/ESP/esp-idf/components/esptool_py/esptool/esptool.py", line 2865, in <module>
    _main()
  File "/Users/prasaddezoysa/Documents/Projects/Electronics/Projects/ESP/esp-idf/components/esptool_py/esptool/esptool.py", line 2858, in _main
    main()
  File "/Users/prasaddezoysa/Documents/Projects/Electronics/Projects/ESP/esp-idf/components/esptool_py/esptool/esptool.py", line 2565, in main
    esp = chip_class(each_port, initial_baud, args.trace)
  File "/Users/prasaddezoysa/Documents/Projects/Electronics/Projects/ESP/esp-idf/components/esptool_py/esptool/esptool.py", line 213, in __init__
    self._port = serial.serial_for_url(port)
  File "/Library/Python/2.7/site-packages/serial/__init__.py", line 88, in serial_for_url
    instance.open()
  File "/Library/Python/2.7/site-packages/serial/serialposix.py", line 272, in open
    self._reconfigure_port(force_update=True)
  File "/Library/Python/2.7/site-packages/serial/serialposix.py", line 438, in _reconfigure_port
    [iflag, oflag, cflag, lflag, ispeed, ospeed, cc])
termios.error: (22, 'Invalid argument')
make: *** [flash] Error 1

Return to “Hardware”

Who is online

Users browsing this forum: shaileshbakshi and 5 guests