Some few randoms errors on UART serial communication

mr.DisplayName
Posts: 2
Joined: Mon Sep 16, 2019 11:44 am

Some few randoms errors on UART serial communication

Postby mr.DisplayName » Mon Sep 16, 2019 12:08 pm

Hello, I wondered if someone has had the same issue as me and if anyone has a solution. I have made a simple board with the Wroom 32D. When I hook it up with serial com at 115200 baud. Most of the text is transferred correctly. However, some random characters are wrong. I have an example of the output beneath when I restart the mcu.

Code: Select all

rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff0018,len:4
load:0x3gfn001c,le~:56�6
load:0x40078000,len:0
ho 12 tail 0 room 4
load:0x40078000,len:13844
entry 0x40078fc4
␀␀�+L�&�[R��30) boot: ESP-IDF v3.0.7 2nd stage bootloader␛[0m
␎�[0;32mI (30) boot: Enabling RNG early entropy source...␛[0m
␛[0;32mI (35) boot: SPI Speed      : 40MHz␛[0m
␛[0;32mI (39) boot: SPI Mode       : DIO␛[0m
␛[0;32mI (43) boot: SPI Flash Size : 4MB␛[0m
␛[0;32mI (47) boot: T�rt�tmon$Table:␛[0m
␛[0;32mI (51) boot: ## Label            Usage          Type ST Offset   Length␛[0m
␛[0;32mI (58) boot:  0 phy_init         RF data          01 01 0000f000 00001000␛[0m
␛[0;32mI (65) boot:  1 otadata        � O�A$�ata         01 00 00010000 00002000␛[0m
␛[0;32mI (73) boot:  2 nvs              WiFi data        01 02 00012000 0000e000␛[0m
␛[0;32mI (80) boot:  3 at_customize     unknown          40 00 00020000 000e0000␛[0m
␛[0;32mI (88� boot:  4 ota_0            OTA app (        00 10 00100000 00180000␛[0m
␛[0;32mI (95) boot:  5 ota_1            OTA app          00 11 00280000 00180000␛[0m
␛[0;32mI (103) boot: End of partition table␛[0m
␛[0;32mI (107) boot: No factory image, tryino OTA 0␛[0m
␛[0;32mI (112) esp_image: segment 0: paddr=0x00100020 vaddr=0x3f400020 size=0x20614 (132628) map␛[0m
␀␀␀@␀␀␀@␀␀␀@␐␀␀␀␀␀␀␀␀␀� �␛[0;32mI (167) esp_image: segment 1: paddr=0x0012063c vaddr=0x3ffc0000 size=0x02d7c ( 11644) load␛[0m
␛[0;32mI (172) esp_image: segment 2: paddr=0x0p1233cp vadfr=2x42p80p00 size=0x00400 (  1024) load␛[0m
␛[0;32mI (175) esp_image: segment 3: paddr=0x001237c8 vaddr=0x40080400 size=0x0c848 ( 51272) load␛[0m
␛[0;32mI (204) esp_image: segment 4: paddr=0x00130018 vaddr=0x400d0018 size=0xdfc80 (916608) map␛[0m
␁␀␀␀␀@␐␄␀␀␀␀␀␀@␀␄␀␀␀@␐␀�␀␀␀␐␀@␐␀@␀␄␁␀␀␀␀␀␀␂␀@␀��␀␀␀␀@␀@␐␀␀␀␀␀␀␀�␀␀␂@␐␀`�␀␀␀@␐␄␁␀␀␀␀@␐␄␁␀␀␀␀␀␀␀␀␀�␃␀␀␀␀␀␄␀␀␀@␀␀@␐␄␀␀␀␀␀@␐��␁␀␀@␐␄␁␀␀␀� ␀␂@␐␄␁␀␀␀␀␄␀@␘�␁␀@␀␄␁␀␀␀␀␀␀␀␀␐␄␁␀␀␀� ␀�␁␀␀␀␀@␐␀@␀␄␁␀␀␀␀␀␀␀␀␀@0��␁␀@␐␄␀␀␀␀�␀@␐␄␀␀␀␀␀␀��␀␀␀@␀␀@␀␄␁␀␀␀␀␀␀␀␀␀@␐␄��␀␀@␀␀␀␀␀␄␁␀␀␀␀␀␀␂@␀@␐�␀␀␀␀@␀␄␀␀␀␀␀␀␀␀@␐␀␀␀@␐0�␀␀␀␀␀␀␀␀␀@␐␀@␐␄␀@␐␄␁␀�␀␀␀␀␀@␐␄␀␀␀␀␀␀␀@␐␄␁␀␀␀␀��␀␀␀@␀␀␀␀␀@␐␄␀␀␀␀␀␀␀␀␀␀␀�␛[0;32mI (526) esp_image: segment 5: paddr=0x0020fca0 vaddr=0x4008cc48 size=0x02504 (  9476) 
load␛[0m
␛[0;32mI (530) esp_image: segment 6: paddr=0x002121ac vaddr=0x400c0008 size=0x80064 (   100) load␛[0m
␛[0;32mI (541) boot: Loaded app from partition at offset 0x100000␛[0m
␛[0;32mI (541) boot: Disabling RNG early entropy source...␛[0m
So far I have tested:
-The FTDI usb to serial module I use. It works fine on a ESP32 doit board.
-Cheked if the signal is noisy compaired to the ESP32 doit board, turns out my board's serial is a lot less noisy.
-Used a lab power supply to deliver the power instead of the regulator I added on the board, so I can rule out a noisy power supply.
-Removed all the components on the board except those who are essential for the wroom and uart. Or those I think are essential.
-Tested three different wroom 32d modules, to make sure the module wasn't faulty.

Edit from cheking the baud rate with the ocilloscope it seems to be about 116280.

mr.DisplayName
Posts: 2
Joined: Mon Sep 16, 2019 11:44 am

Re: Some few randoms errors on UART serial communication

Postby mr.DisplayName » Tue Sep 17, 2019 8:09 am

I found the solution. Turns out it was because the ftdi chip and mcu did not share groud. I did not expect it to be a problem since it worked fine with the doit dev board.

Who is online

Users browsing this forum: No registered users and 9 guests