ESP32 RTC GPIO problem

__illia__
Posts: 1
Joined: Mon Nov 11, 2019 5:51 pm

ESP32 RTC GPIO problem

Postby __illia__ » Mon Nov 11, 2019 6:01 pm

Hi

I faced a problem with RTC GPIO. As I ran out of normal GPIO's I am trying to use GPIO35 as an output, while normally this is GPI input only pin.

I tried this code:

Code: Select all

    rtc_gpio_init(35);
    rtc_gpio_set_direction(35, RTC_GPIO_MODE_OUTPUT_ONLY);
    rtc_gpio_set_level(35, 1);
It is compiled and executed without any errors but pin stays low.

I also tried to add pull up:

Code: Select all

    rtc_gpio_pullup_en(35);
but it did not work either.

Also I tried to use number 5 instead of 35 (because GPIO35 is RTC_GPIO5) but then I received errors while calling all described functions, so definetely it's not the root of problem.

Am I missing something? or this pin can't be used as output at all? thanks.

WiFive
Posts: 2822
Joined: Tue Dec 01, 2015 7:35 am

Re: ESP32 RTC GPIO problem

Postby WiFive » Tue Nov 12, 2019 2:50 am

or this pin can't be used as output at all?
Correct

Who is online

Users browsing this forum: No registered users and 9 guests