ESP32 DEVKITC WROVER-IB - jtag / openocd communication problems

lafar6502
Posts: 22
Joined: Fri Mar 27, 2020 8:26 pm

ESP32 DEVKITC WROVER-IB - jtag / openocd communication problems

Postby lafar6502 » Tue Mar 31, 2020 7:19 am

Hi,

I have an esp32 DevkitC WROVER-IB board and two esp-32s NodeMCU clones (WROOM)
And a problem - I'm not able to JTAG-debug the WROVER-IB board. Openocd shows JTAG scan errors (all ones or all zeros) and no communication. At the same time I'm able to run the debug session on the wroom boards. So it's verified that the wiring is allright and ESP-Prog board is set up correctly, the only thing that differs is the board model.
I'm able to flash the WROVER board via USB connection and run some programs on it, so the board is functional, only the JTag is not working.
Are there any differences in jtag pins between this wrover board and all these esp32 wroom / nodemcu clones?


https://www.espressif.com/sites/default ... eet_en.pdf

my connections
GPIO12 — AD1 (TDI)
GPIO15 — AD2 (TDO)
GPIO13 — AD0 (TCK)
GPIO14 — AD3 (TMS)
GND — GND
VCC -- 5V

ESP_Sprite
Posts: 3732
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP32 DEVKITC WROVER-IB - jtag / openocd communication problems

Postby ESP_Sprite » Tue Mar 31, 2020 7:52 am

Are you sure the offending board isn't running some firmware that repurposes GPIO12-15 for something else?

lafar6502
Posts: 22
Joined: Fri Mar 27, 2020 8:26 pm

Re: ESP32 DEVKITC WROVER-IB - jtag / openocd communication problems

Postby lafar6502 » Wed Apr 01, 2020 6:54 am

no, even the simplest blink example did not work..
but i got it to work, however i dont have the explanation or understanding of what happened
First of all, switched the jtag interface from esp-prog to generic ftdi 2232 board
Second, switched openocd board config script from esp32-wroom to esp32-wrover
But these scripts are almost identical, the only difference is that esp32.wrover.cfg has this line
set ESP32_FLASH_VOLTAGE 1.8
and the script for wroom doesnt have it. Can anyone confirm that this is flash voltage option is the reason for jtag communication problem?

ESP_Sprite
Posts: 3732
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP32 DEVKITC WROVER-IB - jtag / openocd communication problems

Postby ESP_Sprite » Wed Apr 01, 2020 8:40 am

No, a wrong flash voltage should result in scan errors; it usually will lead to crashes of the CPU core but not the JTAG system. Weird.

el_kadenaz
Posts: 1
Joined: Fri May 15, 2020 7:03 am

Re: ESP32 DEVKITC WROVER-IB - jtag / openocd communication problems

Postby el_kadenaz » Fri May 15, 2020 7:08 am

Hi, I was experimenting the same issue...
Fixed moving th flash voltage to 3.3 according to this document:
https://www.espressif.com/sites/default ... eet_en.pdf
NOTE at page six

Who is online

Users browsing this forum: No registered users and 16 guests