Problem on a esp32 doit-devkit-v1 when powered using VIN pin (serial port 2 error)

JorgeMaker
Posts: 3
Joined: Thu Oct 15, 2020 10:39 pm

Problem on a esp32 doit-devkit-v1 when powered using VIN pin (serial port 2 error)

Postby JorgeMaker » Thu Oct 15, 2020 10:50 pm

Hi everyone,

I have developed my code that runs on an esp32doit-devkit-v1 board and it works correctly if I power it through the UBS connector.

However when I power the board using the VIN pin it stops working correctly. The problem that appears is with serial port 2.

Does anyone know what may be happening and how I could do to fix it?

Thanks in advance for your help.

PS: I do not post any code since i am convinced that is a hardware isssue.

ESP_Sprite
Posts: 4011
Joined: Thu Nov 26, 2015 4:08 am

Re: Problem on a esp32 doit-devkit-v1 when powered using VIN pin (serial port 2 error)

Postby ESP_Sprite » Fri Oct 16, 2020 1:00 am

Define 'stops working correctly'? Define 'the problem' that appears with serial port 2?

JorgeMaker
Posts: 3
Joined: Thu Oct 15, 2020 10:39 pm

Re: Problem on a esp32 doit-devkit-v1 when powered using VIN pin (serial port 2 error)

Postby JorgeMaker » Fri Oct 16, 2020 4:04 pm

The situation is as described in the following diagram. In case A the ESP32 is powered using USB from the computer everything works properly but the i change to case B powering the ESP32 using a power supply via VIN pin serial communications between ESP32 and Arduino stops working. There is not any error message but communication does not work.

Image

User avatar
ESP_krzychb
Posts: 307
Joined: Sat Oct 01, 2016 9:05 am
Contact:

Re: Problem on a esp32 doit-devkit-v1 when powered using VIN pin (serial port 2 error)

Postby ESP_krzychb » Fri Oct 16, 2020 5:10 pm

Hi JorgeMaker,
In case B I would add GND connection between ESP32 and Arduino.

JorgeMaker
Posts: 3
Joined: Thu Oct 15, 2020 10:39 pm

Re: Problem on a esp32 doit-devkit-v1 when powered using VIN pin (serial port 2 error)

Postby JorgeMaker » Fri Oct 16, 2020 8:08 pm

Thank a lot for you answer @ESP_krzychb i will try your suggestion to see if solves my problem :D

Who is online

Users browsing this forum: No registered users and 9 guests