TX Power Consumption with Impedance Mismatch

chrismerck
Posts: 14
Joined: Tue May 29, 2018 8:00 pm

TX Power Consumption with Impedance Mismatch

Postby chrismerck » Fri Jun 15, 2018 6:19 pm

I noticed that the power consumption of the ESP-WROOM-32U is significantly higher than expected when connecting to WiFi without any antenna connected. This causes my power supply to go into hiccup mode and creates an endless cycle of brownout resets.

While I understand that WiFi/BLE performance will be very poor without an antenna, and the RF PA may even be damaged by lack of antenna, the high power consumption and resulting brownouts prevents the end product from performing other critical functions besides the wireless connectivity. It is possible that the antenna is removed through rough product handling, and it would be highly preferable to have the ESP32 continue to function even if the WiFi/BLE fails due to lack of antenna.

Can anyone confirm or comment on this higher power draw? I could make measurements with an oscilloscope to show time-domain current draw if that would be helpful.

johnlee
Posts: 33
Joined: Sun Nov 15, 2015 4:27 am

Re: TX Power Consumption with Impedance Mismatch

Postby johnlee » Mon Jun 18, 2018 2:25 pm

yes. it could happen depending on what the impedance is at that point. the transceiver is not designed to work under such conditions. Imagine the power amplifier trying to pump 20 dBm of power into a low impedance, and since power is current^2 x R, and R is very small, the current would have to increase.
it would still work but electromigration might eventually kill it after a long while.
If you have inductance on the supply voltage, it might also cause large supply fluctuations, like what a boost DCDC does, and pump up the supply and kill something else along the way.

In a nutshell, it's extremely dangerous to run the transceiver without the antenna! don't do it.

WiFive
Posts: 1820
Joined: Tue Dec 01, 2015 7:35 am

Re: TX Power Consumption with Impedance Mismatch

Postby WiFive » Mon Jun 18, 2018 2:58 pm

johnlee wrote:In a nutshell, it's extremely dangerous to run the transceiver without the antenna! don't do it.


Ok but say a IPEX cable falls off during shipping. Is there a way for the phy to detect this and notify the application?

ESP_Sprite
Posts: 1668
Joined: Thu Nov 26, 2015 4:08 am

Re: TX Power Consumption with Impedance Mismatch

Postby ESP_Sprite » Tue Jun 19, 2018 1:17 am

That would indeed be a good feature to have. I'll ask around to see if we can implement this.

Edit: Analog people tell me they are working on this and have a possible way to do this (both the no-antenna-detection as well as the power draw when no antenna is connected) but they need to run tests to see how well it works. If those tests are successful, we'll add it to esp-idf.

chrismerck
Posts: 14
Joined: Tue May 29, 2018 8:00 pm

Re: TX Power Consumption with Impedance Mismatch

Postby chrismerck » Fri Jun 22, 2018 1:34 pm

Whoah, awesome! That could help improve long-term reliability and self-diagnostic capability. :ugeek:

Who is online

Users browsing this forum: No registered users and 2 guests