Cannot run app on ESP32 from an external battery

sheikhumar93
Posts: 13
Joined: Fri Aug 10, 2018 7:47 am

Cannot run app on ESP32 from an external battery

Postby sheikhumar93 » Sun Aug 19, 2018 7:32 pm

I am trying to run an ESP-IDF app on my ESP32 that sends sensor readings to a web server on my Ubuntu machine, I have attached it to 2 batteries and pins to Vin and Gnd with 3.40V. When I connect the ESP32 to a USB port on my PC, it transmits data just fine to my server. But when I connect it to the batteries it does not transmit any data. Both the ESP32 and the MPU6050's onboard LED power up though. What am I doing wrong here?
Attachments
IMG_0008.JPG
IMG_0008.JPG (961.09 KiB) Viewed 2364 times
IMG_0007.JPG
IMG_0007.JPG (705.3 KiB) Viewed 2364 times

User avatar
kolban
Posts: 1683
Joined: Mon Nov 16, 2015 4:43 pm
Location: Texas, USA

Re: Cannot run app on ESP32 from an external battery

Postby kolban » Mon Aug 20, 2018 3:16 am

If it were me, I'd attach an external UART->USB connector to the RX and TX pins of the ESP32 and see what the console is saying during boot.
Free book on ESP32 available here: https://leanpub.com/kolban-ESP32

ESP_Angus
Posts: 2072
Joined: Sun May 08, 2016 4:11 am

Re: Cannot run app on ESP32 from an external battery

Postby ESP_Angus » Mon Aug 20, 2018 7:43 am

Which pins on the development board are you connecting the 3.4V out of the battery to?

sheikhumar93
Posts: 13
Joined: Fri Aug 10, 2018 7:47 am

Re: Cannot run app on ESP32 from an external battery

Postby sheikhumar93 » Mon Aug 20, 2018 8:02 am

To the VIN and GND pins.
@kolban thanks for the reply, unfortunately I don't have access to a USB->UART connector right now.
Attachments
IMG_0010.JPG
IMG_0010.JPG (305.91 KiB) Viewed 2332 times

User avatar
loboris
Posts: 514
Joined: Wed Dec 21, 2016 7:40 pm

Re: Cannot run app on ESP32 from an external battery

Postby loboris » Mon Aug 20, 2018 2:09 pm

Vin is the LDO input (+5V pin from USB). If the battery voltage is 3.4V, it is probably not enough to give 3.3V on LDO's output (pin 3V3).
You could use the LiFePO4 battery connected directly to 3V3 pin to power the board.

sheikhumar93
Posts: 13
Joined: Fri Aug 10, 2018 7:47 am

Re: Cannot run app on ESP32 from an external battery

Postby sheikhumar93 » Sun Aug 26, 2018 12:07 pm

Hi @loboris, if I connect my 3.4V connection to 3v3, where do I connect my I2C sensor's VCC then?

User avatar
loboris
Posts: 514
Joined: Wed Dec 21, 2016 7:40 pm

Re: Cannot run app on ESP32 from an external battery

Postby loboris » Sun Aug 26, 2018 1:29 pm

sheikhumar93 wrote:Hi @loboris, if I connect my 3.4V connection to 3v3, where do I connect my I2C sensor's VCC then?
It the sensors can be powered from 3.4V, connect them to 3.4V, if thay require some other voltage, you must use separate LDO to power them and some level shifter. Most of the I2C sensors should work with 3.4V.
Be carefull if using Li-Po batteries, fully charged they can have voltage too high for ESP32.

Who is online

Users browsing this forum: No registered users and 9 guests