Documentation for ESP WROVER KIT 4.1

jcsbanks
Posts: 108
Joined: Tue Mar 28, 2017 8:03 pm

Documentation for ESP WROVER KIT 4.1

Postby jcsbanks » Tue Aug 21, 2018 6:36 pm

Is there any documentation for the above?

Particularly looking for any info on the LCD: https://github.com/loboris/ESP32_TFT_library with ESP WROVER KIT preconfig settings doesn't show anything but a white screen even with DIO and 40MHz SPI speed and PSRAM disabled.

The application it arrived with just outputted "debug", flashed the LED on the back, a quarter of the screen had monochrome lines and the other three quarters had colour.

jcsbanks
Posts: 108
Joined: Tue Mar 28, 2017 8:03 pm

Re: Documentation for ESP WROVER KIT 4.1

Postby jcsbanks » Tue Aug 21, 2018 6:50 pm


jcsbanks
Posts: 108
Joined: Tue Mar 28, 2017 8:03 pm

Re: Documentation for ESP WROVER KIT 4.1

Postby jcsbanks » Tue Aug 21, 2018 7:01 pm

Code: Select all

// ** Set the correct configuration for ESP32-WROVER-KIT v4.1
// --------------------------------------------------------
#define DEFAULT_DISP_TYPE           DISP_TYPE_ILI9341
#define DEFAULT_TFT_DISPLAY_WIDTH   240
#define DEFAULT_TFT_DISPLAY_HEIGHT  320
#define DISP_COLOR_BITS_24          0x66
#define DEFAULT_GAMMA_CURVE         0
#define DEFAULT_SPI_CLOCK           26000000
#define TFT_INVERT_ROTATION         0
#define TFT_INVERT_ROTATION1        0
#define TFT_RGB_BGR                 0x08


Works with PSRAM enabled, flash and PSRAM at 80MHz, QIO.

Dardan
Posts: 1
Joined: Thu Sep 06, 2018 12:50 pm

Re: Documentation for ESP WROVER KIT 4.1

Postby Dardan » Thu Sep 06, 2018 1:02 pm

esp-wrover_kit 4.1
arduiono ide 1.8.2
Used library "WROVER_KIT_LCD.h"
Project "spitftbitmap.ino"

If the SD card is removed, the LCD works normally, if inserted, the screen is white. The Internet does not know the problem :D . Can developers or experienced professionals tell me what the problem is?

Who is online

Users browsing this forum: No registered users and 7 guests