Problems with starting menuconfig

JustMeNL777
Posts: 2
Joined: Wed Jun 12, 2019 9:05 am

Problems with starting menuconfig

Postby JustMeNL777 » Wed Jun 12, 2019 9:12 am

I have problems starting make menuconfig for the hello world example in the setup guide. My machine is a Mac running 10.14.5.

I followed the guide @https://docs.espressif.com/projects/esp ... setup.html but got to this point:

Code: Select all

MacBook-577:hello_world user$ python -m pip install --user -r $IDF_PATH/requirements.txt
Requirement already satisfied: setuptools in /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages (from -r /Users/user/esp32-idf/esp-idf/requirements.txt (line 4)) (40.8.0)
Requirement already satisfied: pyserial>=3.0 in /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages (from -r /Users/user/esp32-idf/esp-idf/requirements.txt (line 8)) (3.4)
Requirement already satisfied: future>=0.15.2 in /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages (from -r /Users/user/esp32-idf/esp-idf/requirements.txt (line 9)) (0.17.1)
Requirement already satisfied: cryptography>=2.1.4 in /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages (from -r /Users/user/esp32-idf/esp-idf/requirements.txt (line 10)) (2.3.1)
Requirement already satisfied: pyparsing<2.4.0,>=2.0.3 in /Users/user/Library/Python/3.7/lib/python/site-packages (from -r /Users/user/esp32-idf/esp-idf/requirements.txt (line 11)) (2.3.1)
Requirement already satisfied: pyelftools>=0.22 in /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages (from -r /Users/user/esp32-idf/esp-idf/requirements.txt (line 12)) (0.25)
Requirement already satisfied: idna>=2.1 in /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages (from cryptography>=2.1.4->-r /Users/user/esp32-idf/esp-idf/requirements.txt (line 10)) (2.8)
Requirement already satisfied: cffi!=1.11.3,>=1.7 in /Users/user/Library/Python/3.7/lib/python/site-packages (from cryptography>=2.1.4->-r /Users/user/esp32-idf/esp-idf/requirements.txt (line 10)) (1.12.3)
Requirement already satisfied: asn1crypto>=0.21.0 in /Users/user/Library/Python/3.7/lib/python/site-packages (from cryptography>=2.1.4->-r /Users/user/esp32-idf/esp-idf/requirements.txt (line 10)) (0.24.0)
Requirement already satisfied: six>=1.4.1 in /Users/user/Library/Python/3.7/lib/python/site-packages (from cryptography>=2.1.4->-r /Users/user/esp32-idf/esp-idf/requirements.txt (line 10)) (1.12.0)
Requirement already satisfied: pycparser in /Users/user/Library/Python/3.7/lib/python/site-packages (from cffi!=1.11.3,>=1.7->cryptography>=2.1.4->-r /Users/user/esp32-idf/esp-idf/requirements.txt (line 10)) (2.19)
MacBook-577:hello_world user$ make menuconfig
The following Python requirements are not satisfied:
cryptography>=2.1.4
pyparsing>=2.0.3,<2.4.0
pyelftools>=0.22
Please refer to the Get Started section of the ESP-IDF Programming Guide for setting up the required packages.
Alternatively, you can run "/usr/bin/python -m pip install --user -r /Users/user/esp32-idf/esp-idf/requirements.txt" for resolving the issue.
MacBook-577:hello_world user$ 
Can someone help me to get this working?

User avatar
roland
Posts: 22
Joined: Tue Oct 09, 2018 10:28 am

Re: Problems with starting menuconfig

Postby roland » Wed Jun 12, 2019 12:50 pm

Hi JustMeNL777,

is the output of "which python" /usr/bin/python or something else?

JustMeNL777
Posts: 2
Joined: Wed Jun 12, 2019 9:05 am

Re: Problems with starting menuconfig

Postby JustMeNL777 » Thu Jun 13, 2019 4:25 pm

@Roland,

Thank you. You triggered me to check versions. The output of which python is /usr/bin/python, which on a mac is 2.7.10.
The buidllog above shows 3.7 was used.

I went to /usr/bin and issued the python - m pip install --user -r $IDF_PATH\requirements.txt again and it installed the missing pieces (after moaning about other missing pieces which I had to install manually).

Anyway: (this) problem solved, on to the next.

Who is online

Users browsing this forum: Baidu [Spider] and 22 guests