Page 1 of 1

ESP-IDF v3.3 LTS clarification

Posted: Thu Sep 05, 2019 2:05 pm
by mikemoy
I think my understanding of the releases might be wrong. Can someone please break this down for me.
I use CMake, and with the new notice of "ESP-IDF v3.3 has been released (LTS)" here:
viewtopic.php?f=13&t=12162#p48785

I want to be sure I am using the correct one. The setup for Cmake is here:
https://docs.espressif.com/projects/esp ... setup.html

When I run the tool you are given these choices. Is "release/v3.3" the LTS one ?


Annotation 2019-09-05 084843.png
Annotation 2019-09-05 084843.png (18.75 KiB) Viewed 2054 times

I ask because when you click on the bottom of the web page you get this popup. Which confuses me.
I am only interested in v3.3 LTS, so as you can see there are 4 possibilities.
stable, v3.3, v3.3-rc, and release-v3.3. Can someone breakdown what these 4 mean.



Annotation 2019-09-05 083546.png
Annotation 2019-09-05 083546.png (30.95 KiB) Viewed 2054 times

Re: ESP-IDF v3.3 LTS clarification

Posted: Fri Sep 06, 2019 6:55 am
by ESP_Angus
Hi Mikemoy,

Sorry for the confusion, v3.3 is the new LTS release.

The installer metadata wasn't updated yesterday but it should be updated now, so "v3.3" should appear as an option if you run it again. Or you can download the release from Github here: https://github.com/espressif/esp-idf/releases/v3.3

The relevant docs are here: https://docs.espressif.com/projects/esp-idf/en/v3.3/

("latest" docs, as linked from the post, are for the development version, currently v4.1-dev, and they will describe some things differently.)
stable, v3.3, v3.3-rc, and release-v3.3. Can someone breakdown what these 4 mean.
"stable" will always be the latest stable release, this is "v3.3" at the moment but will change in the future when a new stable release comes out.
"v3.3" is the link for v3.3 docs.
"v3-3-rc" was the v3.3 Release Candidate prerelease version. This will be taken down shortly.
"release-v3.3" is the "release branch" for v3.3, "release/v3.3". This branch is updated regularly with bugfixes and other changes, and will be used to make bugfix releases (ie v3.3.1, etc).

You can find some more advice about how to pick a version here:
https://docs.espressif.com/projects/esp ... sions.html

(This document doesn't describe LTS versions yet as this is a new addition, but it will describe them soon.)

Re: ESP-IDF v3.3 LTS clarification

Posted: Sat Sep 07, 2019 9:32 pm
by mikemoy
@ESP_Angus, thank you for clarifying that up for me!

I would like to resolve other confusion for me.
Concerning the documentation for installing the tool chain. I find that the " ESP-IDF Tools Installer " section, for v3.3 uses a different version of esp-idf-tools-setup.exe than the latest? Is this just missed, or when using v3.3 i should use esp-idf-tools-setup-1.2.exe, over esp-idf-tools-setup-2.0.exe ?


v3.3 Link
https://docs.espressif.com/projects/esp ... -installer

latest link.
https://docs.espressif.com/projects/esp ... -installer

Re: ESP-IDF v3.3 LTS clarification

Posted: Sun Sep 08, 2019 6:30 pm
by jcsbanks
On 5th September just after it was announced I updated and see this:

Code: Select all

$ git status
On branch release/v3.3
Your branch is up to date with 'origin/release/v3.3'.
The binary from the build shows:

13:39:25 Sep 5 2019 v3.3-rc-24-g148a26980

Is the -rc just an old tag?

I did not notice this until I asked for our first 50 production items to be programmed having awaited the release of 3.3. All seems to be working, but if there are any crucial updates I'll update again before more are programmed.

Re: ESP-IDF v3.3 LTS clarification

Posted: Mon Sep 09, 2019 1:25 am
by ESP_Angus
Hi jcsbank,
jcsbanks wrote:
Sun Sep 08, 2019 6:30 pm
13:39:25 Sep 5 2019 v3.3-rc-24-g148a26980
Sorry for the inconvenience, as you probably know we use an automated CI system to run unit tests and then deploy to GitHub, and sometimes it fails (due to issues with servers in China talking to GitHub, or issues with the automated test environment, etc)

In this case the release/v3.3 branch didn't deploy but the "v3.3" tag did (tags run in separate jobs to branches). So the release/v3.3 branch was a few commits behind the "v3.3" release tag, for no good reason.

I've just manually updated the release/v3.3 branch on GitHub so if you pull again then you should have the v3.3 release. You can check the commit log to see what was changed between commit 148a26980 and the release.

Re: ESP-IDF v3.3 LTS clarification

Posted: Mon Sep 09, 2019 8:46 am
by jcsbanks
Thanks. Nothing critical for us between those commits. It is exciting to get product near release! Thanks for all the support, you guys rock :)

Re: ESP-IDF v3.3 LTS clarification

Posted: Sun Sep 29, 2019 7:34 pm
by ajaymm58
mikemoy wrote:
Sat Sep 07, 2019 9:32 pm
WRT: use esp-idf-tools-setup-1.2.exe, over esp-idf-tools-setup-2.0.exe
I would also like to understand if ". . .2.0.exe" can be used for building esp-idf v3.3 or not.
Else, considering v3.3 is LTS but CMAKE toolchain is "preview" only; is there a plan to support v3.3 and v4.x with the same version of tools?

Re: ESP-IDF v3.3 LTS clarification

Posted: Wed Oct 09, 2019 9:13 am
by ESP_igrr
The documented approach is to use the -1.2 installer to v3.3, and use the -2.0 (now -2.1) installer for 4.x.

However, the 2.1 installer actually includes some logic to support v3.3 version. If you choose to download the v3.3.x release using the installer, it will create an "IDF command prompt" shortcut, where v3.3 CMake environment will work. The only issue is that the installer only creates one shortcut, so if you later use the installer to also install v4.0, the shortcut will be overwritten. You can work around this by copying the shortcut somewhere else (e.g. the Desktop) or renaming it, before running the installer again. This is mentioned in the docs: https://docs.espressif.com/projects/esp ... and-prompt (third paragraph).