Running esp-azure device twin sample: esp-tls: write error :-80 and mqtt issue

zliudr
Posts: 41
Joined: Thu Oct 03, 2019 5:15 am

Running esp-azure device twin sample: esp-tls: write error :-80 and mqtt issue

Postby zliudr » Thu Oct 03, 2019 5:40 am

I am very new to esp32 development in c/c++. I've used micropython on esp32 and that was such a nice thing. Compiling esp-azure sample code takes over 6 minutes on my decent machine.

Anyway, I encountered this error while running the iothub_devicetwin_samples_and_methods code. I posted an issue at that repo but feat that there's not many people reading that repo.

I have azure account, created a device. Have host name, device id and sharedaccesskey.

Everything looks good on azure. I'm very new with azure too. I can see under devicetwin that the "car" shows up with all its properties, make, oil change, etc.

Now the issues:
I am trying to update devicetwin say the maxspeed. I went in and change maxspeed to 70, save it. A second after saving, it reverts to the 100, which is the value initially sent by esp.

On esp side, mqtt seems to have trouble connecting:
Error: Time:Thu Oct 3 04:58:37 2019 File:D:/Downloads/msys32_iot/home/user/esp/esp-azure/azure-iot-sdk-c/iothub_client/src/iothubtransport_mqtt_common.c Func:mqtt_error_callback Line:1864 Mqtt Ping Response was not encountered. Reconnecting device...
This pops up once in a while, meaning esp keeps trying but mqtt just won't work.

I also tried direct method. The sample code seems to have getCarVIN method to return a VIN and returns { } for all other methods. I tried this method several times and got null. Coincidentally, the esp side shows:
E (246635) esp-tls: write error :-80:
Info: Error from SSL_write: -80
E (246645) esp-tls: write error :-80:
Info: Error from SSL_write: -80

I've downloaded the latest msys (2018-10) and V3.3 of esp-idt and followed the install instructions. I really appreciate if someone could give me a hand here.

zliudr
Posts: 41
Joined: Thu Oct 03, 2019 5:15 am

Re: Running esp-azure device twin sample: esp-tls: write error :-80 and mqtt issue

Postby zliudr » Thu Oct 03, 2019 3:37 pm

And sorry about posting twice. I didn't catch the message after first attempt that this needed admin approval. I saw it the second time :oops:

Who is online

Users browsing this forum: No registered users and 20 guests