[solved] {fmt} and xtensa-esp32-elf-g++ 8.2.0 (crosstool-NG esp32-2019r1)

Posts: 384
Joined: Sun May 14, 2017 5:36 pm

[solved] {fmt} and xtensa-esp32-elf-g++ 8.2.0 (crosstool-NG esp32-2019r1)

Postby permal » Tue Oct 08, 2019 6:16 pm


I'm trying to use {fmt} (https://fmt.dev) in my project, but I'm stuck on the linker step - I suspect that there are missing pieces in the toolchain.

The first few lines of the error message are these:

Code: Select all

externals/fmt/libfmtd.a(format.cc.obj):(.literal+0x0): undefined reference to `__xpg_strerror_r'                      
externals/fmt/libfmtd.a(format.cc.obj):(.literal+0x2c): undefined reference to `std::allocator<char>::allocator()'    
externals/fmt/libfmtd.a(format.cc.obj):(.literal+0x30): undefined reference to `std::allocator<char>::~allocator()'   
externals/fmt/libfmtd.a(format.cc.obj):(.literal+0x34): undefined reference to `fputc'                                
externals/fmt/libfmtd.a(format.cc.obj):(.literal+0x68): undefined reference to `std::allocator<wchar_t>::allocator()' 
externals/fmt/libfmtd.a(format.cc.obj):(.literal+0x6c): undefined reference to `std::allocator<wchar_t>::~allocator()'
externals/fmt/libfmtd.a(format.cc.obj):(.literal+0x70): undefined reference to `fputws'                            
Is this something Espressif devs recognise as not implemented in the named tool chain?


Update: These are all implemented - its just one of my project that fails with these errors for some reason, others builds fine with {fmt}.

Who is online

Users browsing this forum: No registered users and 24 guests