JTAG Driver not talking to Openocd in Umbutu

jcherry4
Posts: 1
Joined: Sun Oct 20, 2019 2:14 pm

JTAG Driver not talking to Openocd in Umbutu

Postby jcherry4 » Sun Oct 20, 2019 3:04 pm

Has anyone had a similar problem?

I am using an FTDI C232HM cable and installed the latest driver libftd2xx.so.1.4.8
I have verified the driver installed by running EEPROM Read:

Library version = 0x10408
Opening port 0
FT_Open succeeded. Handle is 0x55e914cffb60
FT_GetDeviceInfo succeeded. Device is type 8.
FT_EE_Read succeeded.

Signature1 = 0
Signature2 = -1
Version = 5
VendorId = 0x0403
ProductId = 0x6014
Manufacturer = FTDI
ManufacturerId = FT
Description = C232HM-DDHSL-0
SerialNumber = FT0EAUR9
MaxPower = 500
PnP = 1
SelfPowered = 0
RemoteWakeup = 1
Returning 0


When I try running openocd using the following command:
openocd -f interface/ftdi/esp32_devkitj_v1.cfg -f board/esp-wroom-32.cfg
I get the following:

Open On-Chip Debugger v0.10.0-esp32-20190708 (2019-07-08-11:03)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
none separate
adapter speed: 20000 kHz
Info : Configured 2 cores
esp32 interrupt mask on
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Error: no device found
Error: unable to open ftdi device with vid 0403, pid 6010, description '*', serial '*' at bus location '*'

Warn : Flash driver of esp32.flash does not support free_driver_priv()
Warn : Flash driver of irom does not support free_driver_priv()
Warn : Flash driver of drom does not support free_driver_priv()


I also tried running:
openocd -f interface/ftdi/c232hm.cfg -f board/esp-wroom-32.cfg
with the following result:

Open On-Chip Debugger v0.10.0-esp32-20190708 (2019-07-08-11:03)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
adapter speed: 20000 kHz
Info : Configured 2 cores
esp32 interrupt mask on
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Error: libusb_open() failed with LIBUSB_ERROR_ACCESS
Error: no device found
Error: unable to open ftdi device with vid 0403, pid 6014, description '*', serial '*' at bus location '*'

Warn : Flash driver of esp32.flash does not support free_driver_priv()
Warn : Flash driver of irom does not support free_driver_priv()
Warn : Flash driver of drom does not support free_driver_priv()

I am running Ubuntu 18.04.3 LTS using VirtualBox 6.0 with Windows 7 as host

Any help with this would be much appreciated
John

Who is online

Users browsing this forum: AlexESP32, dem0stenes, MSN [Bot] and 18 guests