Installing tools: Unsupported archive type OSX

bobolink
Posts: 37
Joined: Mon Feb 26, 2018 4:17 pm

Installing tools: Unsupported archive type OSX

Postby bobolink » Mon Nov 11, 2019 4:29 pm

Following this: https://docs.espressif.com/projects/esp ... et-esp-idf
Checked this: https://github.com/espressif/esp-idf/issues/4297
Failed.
Any help for me?

Extracting /Users/bobh/.espressif/dist/xtensa-esp32s2-elf-gcc8_2_0-esp32s2-dev-4-g3a626e-macos.tar.gz to /Users/bobh/.espressif/tools/xtensa-esp32s2-elf/esp32s2-dev-4-g3a626e9-8.2.0
Traceback (most recent call last):
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 1344, in <module>
main(sys.argv[1:])
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 1340, in main
action_func(args)
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 1135, in action_install
tool_obj.install(tool_version)
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 595, in install
unpack(archive_path, dest_dir)
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 255, in unpack
raise NotImplementedError('Unsupported archive type')
NotImplementedError: Unsupported archive type
Last edited by bobolink on Mon Nov 11, 2019 4:31 pm, edited 1 time in total.

User avatar
ESP_Roland
Posts: 31
Joined: Tue Oct 09, 2018 10:28 am

Re: Installing tools: Unsupported archive type OSX

Postby ESP_Roland » Tue Nov 12, 2019 6:56 am


bobolink
Posts: 37
Joined: Mon Feb 26, 2018 4:17 pm

Re: Installing tools: Unsupported archive type OSX

Postby bobolink » Tue Nov 12, 2019 5:19 pm

That looks like a Windows patch.
Removing the space from the url in /tools/tools.json doesn’t work either.
OK two spaces must be removed.

bobolink
Posts: 37
Joined: Mon Feb 26, 2018 4:17 pm

Re: Installing tools: Unsupported archive type OSX

Postby bobolink » Tue Nov 12, 2019 5:53 pm

And now this

./install.sh
Installing ESP-IDF tools
Installing tools: xtensa-esp32-elf, xtensa-esp32s2-elf, esp32ulp-elf, openocd-esp32
Skipping xtensa-esp32-elf@esp32-2019r1-8.2.0 (already installed)
WARNING: directory for tool xtensa-esp32s2-elf version esp32s2-dev-4-g3a626e9-8.2.0 is present, but tool was not found
Installing xtensa-esp32s2-elf@esp32s2-dev-4-g3a626e9-8.2.0
Downloading xtensa-esp32s2-elf-gcc8_2_0-esp32s2-dev-4-g3a626e-macos.tar.gz to /Users/bobh/.espressif/dist/xtensa-esp32s2-elf-gcc8_2_0-esp32s2-dev-4-g3a626e-macos.tar.gz.tmp
Traceback (most recent call last):
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 1344, in <module>
main(sys.argv[1:])
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 1340, in main
action_func(args)
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 1134, in action_install
tool_obj.download(tool_version)
File "/Users/bobh/esp/esp-idf/tools/idf_tools.py", line 568, in download
urlretrieve(url, local_temp_path, report_progress if not global_non_interactive else None)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib.py", line 98, in urlretrieve
return opener.retrieve(url, filename, reporthook, data)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib.py", line 245, in retrieve
fp = self.open(url, data)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib.py", line 213, in open
return getattr(self, name)(url)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib.py", line 443, in open_https
h.endheaders(data)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 1049, in endheaders
self._send_output(message_body)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 893, in _send_output
self.send(msg)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 855, in send
self.connect()
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/httplib.py", line 1274, in connect
server_hostname=server_hostname)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/ssl.py", line 352, in wrap_socket
_context=self)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/ssl.py", line 579, in __init__
self.do_handshake()
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/ssl.py", line 808, in do_handshake
self._sslobj.do_handshake()
IOError: [Errno socket error] [Errno 54] Connection reset by peer

User avatar
ESP_Roland
Posts: 31
Joined: Tue Oct 09, 2018 10:28 am

Re: Installing tools: Unsupported archive type OSX

Postby ESP_Roland » Wed Nov 13, 2019 7:38 am

The second one is because the download server was down. Please try it again.

bobolink
Posts: 37
Joined: Mon Feb 26, 2018 4:17 pm

Re: Installing tools: Unsupported archive type OSX

Postby bobolink » Wed Nov 13, 2019 3:17 pm

48 hours later.
____
All done! You can now run:

. ./export.sh
____
"Thank You"

Who is online

Users browsing this forum: No registered users and 20 guests