Page 1 of 1

WiFi LR mode

Posted: Fri Dec 27, 2019 11:08 pm
by Reiner1210
Hello,

is the LR mode actually available ??
The docu for esp_wifi_set_protocol says: Currently we only support 802.11b or 802.11bg or 802.11bgn mode
https://docs.espressif.com/projects/esp ... _wifi.html

Re: WiFi LR mode

Posted: Fri Dec 27, 2019 11:26 pm
by rudi ;-)
Reiner1210 wrote:
Fri Dec 27, 2019 11:08 pm
Hello,

is the LR mode actually available ??
The docu for esp_wifi_set_protocol says: Currently we only support 802.11b or 802.11bg or 802.11bgn mode
https://docs.espressif.com/projects/esp ... _wifi.html

( phy_11b,phy_11g,phy_11n,phy_lr )

you mean this ?

( Macros )
WIFI_PROTOCOL_LR


best wishes
rudi ;-)

Re: WiFi LR mode

Posted: Sat Dec 28, 2019 9:42 am
by Reiner1210
I mean WIFI_PROTOCOL_LR

I have tried it and got an AUTH_EXPIRE when trying to connect

Code: Select all

I (3237) wifi: ap channel adjust o:1,1 n:11,2
I (3237) wifi: new:<11,0>, old:<1,0>, ap:<11,2>, sta:<11,0>, prof:1
I (4747) wifi: state: init -> auth (b0)
I (5747) wifi: state: auth -> init (200)
I (5757) wifi: new:<11,0>, old:<11,0>, ap:<11,2>, sta:<11,0>, prof:11
I (5757) wifi_helper: WIFI_EVENT_STA_DISCONNECTED
I (5757) wifi_helper: Event 'Disconnected' arrived
I (5757) wifi_helper: Disconnected from:
I (5767) wifi_helper:     SSID          : LR_AP
I (5767) wifi_helper:     SSID length   : 5
I (5777) wifi_helper:     BSSID         : 30:ae:a4:7b:91:5d
I (5787) wifi_helper:     Reason        : AUTH_EXPIRE
I (5787) wifi_helper: Start wifi_reconnect_timer
I (125797) wifi_helper: wifi_reconnect_timer_func
I (128247) wifi_helper: WIFI_EVENT_STA_DISCONNECTED
I (128247) wifi_helper: Event 'Disconnected' arrived
I (128247) wifi_helper: Disconnected from:
I (128257) wifi_helper:     SSID          : LR_AP
I (128257) wifi_helper:     SSID length   : 5
I (128267) wifi_helper:     BSSID         : 00:00:00:00:00:00
I (128267) wifi_helper:     Reason        : CONNECTION_FAIL
I (128277) wifi_helper: Start wifi_reconnect_timer
I (248287) wifi_helper: wifi_reconnect_timer_func
I (248407) wifi: new:<11,2>, old:<11,0>, ap:<11,2>, sta:<11,0>, prof:11
I (248407) wifi: state: init -> auth (b0)
I (249407) wifi: state: auth -> init (200)
I (249407) wifi: new:<11,0>, old:<11,2>, ap:<11,2>, sta:<11,0>, prof:11
I (249417) wifi_helper: WIFI_EVENT_STA_DISCONNECTED
I (249417) wifi_helper: Event 'Disconnected' arrived
I (249417) wifi_helper: Disconnected from:
I (249427) wifi_helper:     SSID          : LR_AP
I (249427) wifi_helper:     SSID length   : 5
I (249437) wifi_helper:     BSSID         : 30:ae:a4:7b:91:5d
I (249437) wifi_helper:     Reason        : AUTH_EXPIRE
I (249447) wifi_helper: Start wifi_reconnect_timer


Re: WiFi LR mode

Posted: Sat Dec 28, 2019 10:35 am
by rudi ;-)
Reiner1210 wrote:
Sat Dec 28, 2019 9:42 am
I mean WIFI_PROTOCOL_LR

I have tried it and got an AUTH_EXPIRE when trying to connect

You setup AP in WIFI_PROTOCOL_LR and STATION in WIFI_PROTOCOL_LR?
You setup AUTH Mode AP and STATION same AUTH Mode?

Try this:
change in AP Modul the Protocoll to usually Protocoll you use
and in Station Modul same.
Connect Station to AP and check LOG. If there is no Problem,
then change in AP Modul the Protocoll to WIFI_PROTOCOL_LR
and in Station Modul same. The Auth thing do not change.
Get you again AUTH_EXPIRE ?


You can check which protocoll AP use - > phy_11b,phy_11g,phy_11n,phy_lr
also you can check which protocoll STATION use -> phy_11b,phy_11g,phy_11n,phy_lr
if there is not the same between AP and STATION you can't connect together,
same - you need to use same AUTH Mode in AP and STATION .

Re: WiFi LR mode

Posted: Sat Dec 28, 2019 9:16 pm
by Reiner1210
Yes when I remove _LR and use normal protocols all works fine.
By the way both ESP32 modules are configured as station and as access point.
The first device connects as station in normal way to my WLAN and creates an access point in LR only mode, the second device operates as station in LR only mode (and should connect to the first device). It also creates an access point in normal way which I will use to connect with my laptop.

PS: Now I found out that the station connectiong to my WLAN seems to be the problem. If I do no create the station than it works -..... any idea ???
Reiner

Re: WiFi LR mode

Posted: Sat Dec 28, 2019 10:44 pm
by rudi ;-)
Reiner1210 wrote:
Sat Dec 28, 2019 9:16 pm
Yes when I remove _LR and use normal protocols all works fine.
By the way both ESP32 modules are configured as station and as access point.
The first device connects as station in normal way to my WLAN and creates an access point in LR only mode, the second device operates as station in LR only mode (and should connect to the first device). It also creates an access point in normal way which I will use to connect with my laptop.

Reiner
right?
which connection ( 1,2,3) fails?
_LR_Multi_.jpg
_LR_Multi_.jpg (99.61 KiB) Viewed 2573 times

Re: WiFi LR mode

Posted: Sat Dec 28, 2019 10:52 pm
by rudi ;-)
Reiner1210 wrote:
Sat Dec 28, 2019 9:16 pm
PS: Now I found out that the station connectiong to my WLAN seems to be the problem. If I do no create the station than it works -..... any idea ???
you mean connection 1 ?

if you not use the Station Mode in Device 1 to your (HOME) WLAN
than Connection 2 and Connection 3 works, right?

check it:
do you use the right SSID to your (Home) Wlan from this ESP32 (1) ?
also check the right KEY ( WEP, WPA, WPA2, PSK..)
also a possible:
how is your (Home) Wlan work? DHCP or Static IP?
Get you the right IP's for your want to do?
Is the ESP32 (1) Station MAC in the White List in your (Home) WLAN?
check a block mode in your (Home) Wlan too.

hope this helps
best wishes
rudi ;-)

Re: WiFi LR mode

Posted: Sun Dec 29, 2019 10:58 pm
by Reiner1210
Connection2 fails.
If I disable station (Connection 1) all works fine with LR mode between ESP32 1 and ESP32 2 (but is useless so I dont't tried data transfer).
If I use normal WLAN protocol (bgn) for connection2 it also works.
So it seems that the AP in LR mode does not work when ESP32 is also in station mode (bgn)

Home WLAN uses DHCP and works.
For the LR AP point I gave custom IP, net mask and DHCP range.

I have also opened a bug report
https://github.com/espressif/esp-idf/issues/4554

Re: WiFi LR mode

Posted: Mon Dec 30, 2019 12:05 am
by Reiner1210
I have found a fix for this.
For the station of device 1 I need to enable LR mode also. This is possible because LR mode in station is compatible to bgn. I think it is a strange behaviour and should be documented or fixed :-)

But when I do this I see that I lost the AP on device 2 for normal devices.

Conclusion: LR mode can NOT be set for AP and STA seperately. If it is set in one mode it must be set (or will be set by the device) to the other interface. So it is really only usable for device connection for devices which need NOT to communicate via bgn with the outside world. I will have a look at LoRa devices for long range purpose.

Re: WiFi LR mode

Posted: Thu Apr 09, 2020 6:34 am
by yellowsubmarine
I think you'll be very disappointed with the performance of LoRA unless you're trying to move a very small amount of data. Interoperating between 802.11b/g/n and LR doesn't seem practical (or desirable). Just setup two networks and bridge them in a different manner (or route between them).