esp32 stuck after 4 successive http-ota

ventureg
Posts: 1
Joined: Tue May 19, 2020 7:18 am

esp32 stuck after 4 successive http-ota

Postby ventureg » Tue May 19, 2020 7:34 am

hi,

we are using esp-wroom module in our project. and got stuck while using http-ota.
I can reproduce the problem, but no clue about how to fix it.

Steps to reproduce the problem:
1 make flash to burn the firmware to OTA_0 partition.
2 using http-wifi to OTA the firmware, OTA_0->OTA_1->OTA_0->OTA_1
3 then esp32 got stuck, no more print

here I can use [make monitor] to reset esp32, and from debug info from uart , the last OTA fails.

And I use watchdog to monitor the http-ota process, the watchdog will bite after 60 seconds. But no luck, the esp32 still stuck.

using esptool to retrive chip info:
Chip is ESP32D0WDQ5 (revision (unknown 0xa))

And the partition table is as follows:
*******************************************************************************
# Espressif ESP32 Partition Table
# Name, Type, SubType, Offset, Size, Flags
nvs,data,nvs,0x9000,16K,
otadata,data,ota,0xd000,8K,
phy_init,data,phy,0xf000,4K,
fctry,data,nvs,0x10000,12K,
storage,data,spiffs,0x13000,512K,
ota_0,app,ota_0,0xa0000,1664K,
ota_1,app,ota_1,0x240000,1664K,
*******************************************************************************

WiFive
Posts: 2978
Joined: Tue Dec 01, 2015 7:35 am

Re: esp32 stuck after 4 successive http-ota

Postby WiFive » Wed May 20, 2020 9:29 am

Show the logs

Leander
Posts: 14
Joined: Thu Sep 26, 2019 8:50 pm

Re: esp32 stuck after 4 successive http-ota

Postby Leander » Tue Jun 30, 2020 5:54 pm

Any news on the issue? Got it solved?
When did the ESP got stuck, during the download, upgrade or reboot after upgrade?

Who is online

Users browsing this forum: Bing [Bot] and 53 guests