ESP SMD Breakout Serial Monitor Interference

amoghjain
Posts: 10
Joined: Mon Nov 30, 2020 9:04 am

ESP SMD Breakout Serial Monitor Interference

Postby amoghjain » Fri Jan 08, 2021 10:47 am

Hello,

In my current electrical setup (see attached picture) : I have an
- ESP32 SMD module on a breakout board
- Breakout board is connected to Ubuntu using ESP-Prog's FTDI to UART converter.
- esp32 is connected to WiFi using my phone's hotspot and makes a post every 5 mins.
- another esp DevBoard Module connected to esp breakout board via ESP-Now.

Additionally, previously, I was busting the esp's as I wasnt using any ESD protection, and none of the modules would last more than a couple hours, but now I am using inside of esd shipping packets on my desk, and a esd mat on my soldering desk and both of these are grounded, and have not yet, touched the esp without esd free gloves, and without a grounding strap connected to my arm, so atleast I am positive this problem is not related to esd on esp.

What I have been observing on this new latest board for over 2 days now is,

- random serial characters appear on the serial monitor
- serial monitor stops responding ie doenst show any movement
- Serial starts normally after a while
- Oscilloscope shows peak to peak voltage ripple of 39mV.
but few minutes later, all just goes back to normal.

I can confirm the smd ESP working
- i can send a blink command from wifi to esp on breakout board, which sends command to another esp on devboard and blinks the led.
- esp on breakout board is making regular posts, every 5 mins, and none of them are missing
- I can see esp-prog receive led blink blue, but yet my Ubuntu's serial monitor shows nothing(or just freezes.)


My PCB design is almost done and I am going to order a few soon to confirm this is not some sort of wiring interference/noise. All indications point to some form of noise, corrupting the serial, but since, esp is sending/and recieving the data just fine, I am coming to believe that theres a fault in serial procesing of my laptop, an 8 year old lenovo T530, but since I am not an expert in serial/electronics, I was hoping I could get some insights of the potential issues, or some guidance on what I am try/troubleshoot.

Thanks!
Attachments
serial  jpg.jpg
serial jpg.jpg (2.81 MiB) Viewed 126 times
esp to esp now to laptop wiring.jpg
esp to esp now to laptop wiring.jpg (2.16 MiB) Viewed 126 times
breakout board jpg.jpg
breakout board jpg.jpg (1.96 MiB) Viewed 126 times

Who is online

Users browsing this forum: No registered users and 63 guests