Wifi not working on WROMM-32E but working on the WROOM-32

MarcelKr
Posts: 4
Joined: Thu Jan 14, 2021 1:35 pm

Wifi not working on WROMM-32E but working on the WROOM-32

Postby MarcelKr » Thu Jan 14, 2021 2:03 pm

Hey all,

for some reason the minimal wifi station example is working on an older dev board with an ESP32-WRO)M-32 is working. However on my custom PCB with ESP32-WROOM-32E it is not. It's exactly the same software I'm flashing. On both boards, I first erased the flash via `idf.py erase_flash`.

The dev board's HW:
  • DevKit 4 C clone
  • Powered through USB (Thinkpad docking station)
The custom PCB:
  • Powered through custom step down converter which can deliver up to 1A. Checked via scope: The Output voltage is less noisy compared to the DevKit.
  • The ESP module is placed on the top right corner of the PCB. There's no PCB under the antenna area.
  • Other functions I checked so far worked flawlessly. E.g. LED fading, TWAI, regular GPIO switching.
Attached you find the flashing- and message log of each variant. The problem seems to be with the auth step. Here's an excerpt of the non-working 32E log:

Code: Select all

I (677) wifi_init: WiFi IRAM OP enabled
I (677) wifi_init: WiFi RX IRAM OP enabled
I (787) phy: phy_version: 4500, 0cd6843, Sep 17 2020, 15:37:07, 0, 0
I (797) wifi:mode : sta (7c:9e:bd:d9:b6:50)
I (797) wifi station: wifi_init_sta finished.
I (1517) wifi:new:<6,0>, old:<1,0>, ap:<255,255>, sta:<6,0>, prof:1
I (3467) wifi:state: init -> auth (b0)
I (4467) wifi:state: auth -> init (200)
I (4467) wifi:new:<6,0>, old:<6,0>, ap:<255,255>, sta:<6,0>, prof:1
I (4467) wifi station: retry to connect to the AP
I (4467) wifi station: connect to the AP fail
I (6517) wifi station: retry to connect to the AP
I (6517) wifi station: connect to the AP fail
I (6637) wifi:new:<6,0>, old:<6,0>, ap:<255,255>, sta:<6,0>, prof:1
I (6637) wifi:state: init -> auth (b0)
I (7637) wifi:state: auth -> init (200)
I (7637) wifi:new:<6,0>, old:<6,0>, ap:<255,255>, sta:<6,0>, prof:1
I (7647) wifi station: retry to connect to the AP
Any Idea why on one board it's working whereas it's not on the other?

BR
Marcel

Edit: Corrected attached file and added more info
Attachments
WROOM-32E--CustomPCB.txt
WROOM-32E
WiFi connection is not working
(9.47 KiB) Downloaded 8 times
WROOM-32--DevKitC.txt
WROOM-32
WiFi connection is working
(8.02 KiB) Downloaded 10 times

MarcelKr
Posts: 4
Joined: Thu Jan 14, 2021 1:35 pm

Re: Wifi not working on WROMM-32E but working on the WROOM-32

Postby MarcelKr » Fri Jan 15, 2021 6:31 pm

Any ideas? If not, I'll create a bugticket on github.

BR Marcel

ESP_Minatel
Posts: 43
Joined: Mon Jan 04, 2021 2:06 pm

Re: Wifi not working on WROMM-32E but working on the WROOM-32

Postby ESP_Minatel » Fri Jan 15, 2021 6:54 pm

Hi,

This looks like you are having an issue in the authentication process.

Code: Select all

wifi:state: auth -> init (200)
Have you tried to connect to a different WiFi router?

MarcelKr
Posts: 4
Joined: Thu Jan 14, 2021 1:35 pm

Re: Wifi not working on WROMM-32E but working on the WROOM-32

Postby MarcelKr » Sat Jan 16, 2021 2:50 pm

The exact same software flashed to the DevKitC module is able to connect to this router. I don't suspect the router being the problem. However, I tried to connect to an AP opened via my android phone. No success.

ESP_Minatel
Posts: 43
Joined: Mon Jan 04, 2021 2:06 pm

Re: Wifi not working on WROMM-32E but working on the WROOM-32

Postby ESP_Minatel » Mon Jan 18, 2021 4:49 pm

Hi,

Before creating a new issue on GitHub, you can help by giving your feedback on this issue: https://github.com/espressif/esp-idf/issues/5976

MarcelKr
Posts: 4
Joined: Thu Jan 14, 2021 1:35 pm

Re: Wifi not working on WROMM-32E but working on the WROOM-32

Postby MarcelKr » Mon Jan 18, 2021 8:53 pm

Hey ESP_Minatel, thanks for the hint about the issue. It looks similar but it's closed already and it didn't get solved.

I opened a ticket in the IDF repo on github: https://github.com/espressif/esp-idf/issues/6427

saikrishna
Posts: 1
Joined: Tue Jan 19, 2021 9:17 am

Re: Wifi not working on WROMM-32E but working on the WROOM-32

Postby saikrishna » Tue Jan 19, 2021 9:25 am

I used the sample program esp32/getstarted/wifiap when im trying to connect to the esp32 wifi im getting the following problem'

Code: Select all

I (18662) wifi:station: 38:e6:0a:cd:99:22 join, AID=1, bgn, 20
I (22662) wifi:station: 38:e6:0a:cd:99:22 leave, AID = 1, bss_flags is 134242, bss:0x3ffba7fc

connecting and disconnecting immediately i gave user name as "esp32" and password as "12345678 " and channel 0 and max connections as 5
Help me to solve this ?

Thank you

ESP_Minatel
Posts: 43
Joined: Mon Jan 04, 2021 2:06 pm

Re: Wifi not working on WROMM-32E but working on the WROOM-32

Postby ESP_Minatel » Tue Jan 19, 2021 9:50 am

saikrishna wrote:
Tue Jan 19, 2021 9:25 am
I used the sample program esp32/getstarted/wifiap when im trying to connect to the esp32 wifi im getting the following problem'

Code: Select all

I (18662) wifi:station: 38:e6:0a:cd:99:22 join, AID=1, bgn, 20
I (22662) wifi:station: 38:e6:0a:cd:99:22 leave, AID = 1, bss_flags is 134242, bss:0x3ffba7fc

connecting and disconnecting immediately i gave user name as "esp32" and password as "12345678 " and channel 0 and max connections as 5
Help me to solve this ?

Thank you
Hi,

You need to provide us more information about your issue to receive a proper help.

  • ESP-IDF version?
  • ESP32 Hardware (Dev board or custom)?
  • More debug log since ESP boot
  • Have you tried on different board?
  • Have you tried on different WiFi router?

Who is online

Users browsing this forum: felipe, Thanyasit and 39 guests