Trouble resolving dependencies (Eclipse)

tuskiomi
Posts: 22
Joined: Mon Aug 28, 2017 8:21 pm

Trouble resolving dependencies (Eclipse)

Postby tuskiomi » Wed Dec 19, 2018 8:56 pm

I'm getting a few errors with my custom classes. The errors show up in the IDE, but there is no problem compiling, and using this class works just fine. Even the F3 (open Declaration) function works fine.

Image

after doing some research, people seem to be saying that this is a problem with the CDT, so I posted my CDT settings below, and everything seems to be right.

Image

RbSCRx
Posts: 2
Joined: Wed Dec 19, 2018 9:11 pm

Re: Trouble resolving dependencies (Eclipse)

Postby RbSCRx » Wed Dec 19, 2018 9:18 pm

Have you set the include-paths in the 'Path and symbols' of the project settings?

tuskiomi
Posts: 22
Joined: Mon Aug 28, 2017 8:21 pm

Re: Trouble resolving dependencies (Eclipse)

Postby tuskiomi » Thu Dec 20, 2018 4:40 am

yes, You can see all of my includes here: https://pastebin.com/Zhc8cAh2

RbSCRx
Posts: 2
Joined: Wed Dec 19, 2018 9:11 pm

Re: Trouble resolving dependencies (Eclipse)

Postby RbSCRx » Thu Dec 20, 2018 7:16 pm

Based on this post (viewtopic.php?f=13&t=8512) I assume you're using C++, but in the provided include file you didn't set include paths for C++.

tuskiomi
Posts: 22
Joined: Mon Aug 28, 2017 8:21 pm

Re: Trouble resolving dependencies (Eclipse)

Postby tuskiomi » Fri Dec 21, 2018 5:51 am

Yes, I've duplicated all paths for the C++ portion.

Who is online

Users browsing this forum: No registered users and 9 guests