v3.0 to v3.1 migration guide? WiFi not working...

meowsqueak
Posts: 136
Joined: Thu Jun 15, 2017 4:54 am
Location: New Zealand

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby meowsqueak » Wed Feb 13, 2019 9:32 pm

permal wrote:
Tue Feb 12, 2019 7:47 am
FWIW, I've seen no issues whatsoever with Wifi. I'm always working against the tip of master so I've seen all the versions on my device and I do many, many, soft-resets while developing against my Wrover module.

Are you all sure that it is not something external affecting your wifi-connection?
Well, if I switch back to v3.0, make clean and recompile, it behaves fine. But when I compile against 3.1 and hit reset a few times, the WiFi becomes unreliable to the point of complete failure, and only a power cycle brings it back. I'm not changing anything else, certainly nothing external.

I've also noticed a third state - one where the WIFi connects, but the throughput is very slow - maybe a tenth of what it normally should be.

As mentioned above, I'll gather more info and put together a proper GitHub issue.

littlesky
Posts: 47
Joined: Fri Jun 09, 2017 7:49 am

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby littlesky » Fri Feb 15, 2019 8:59 am

Please update IDF branch release/v3.1. The commit ID of the bugfix is ef2bf2386255514ff0d2bc1b30b638251fd769dd. Please check whether it works for you.

meowsqueak
Posts: 136
Joined: Thu Jun 15, 2017 4:54 am
Location: New Zealand

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby meowsqueak » Sat Feb 23, 2019 1:09 am

littlesky wrote:
Fri Feb 15, 2019 8:59 am
Please update IDF branch release/v3.1. The commit ID of the bugfix is ef2bf2386255514ff0d2bc1b30b638251fd769dd. Please check whether it works for you.
I've rebuilt and flashed my app using espressif/esp-idf commit 57118e2f10a79af0627ed56d42d24584cd4033d8 (which includes that one) and it has not resolved my WiFi problem. In fact now it won't even connect after a power cycle, so it seems even more broken than before - i.e. completely broken as far as WiFi goes.

This is why I'm wondering if there is a code change I need to make since upgrading from v3.0 - perhaps I'm missing something? My code is here (may need to disable a bunch of peripheral-specific functions in the main function to get it to run without crashing).

meowsqueak
Posts: 136
Joined: Thu Jun 15, 2017 4:54 am
Location: New Zealand

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby meowsqueak » Sat Feb 23, 2019 3:06 am

An odd observation - I am powering my ESP32 devkit (DOIT) via an external 5V power supply, and I am also using a USB cable to view the monitor console. I've discovered that when the USB cable is connected, the WiFi RSL reports as zero and the device is unable to connect via WiFi. But if I disconnect the USB cable the WiFi RSL shows about -91 (viewed on an LCD display) and WiFi connects successfully. I'm not sure what the explanation is for this, but I'll try alternative boards and cables in case it's a hardware issue.

meowsqueak
Posts: 136
Joined: Thu Jun 15, 2017 4:54 am
Location: New Zealand

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby meowsqueak » Wed Feb 27, 2019 9:23 am

I'm going to create a GitHub issue for this, but as a final comment for now:

I've tried a couple of ESP32 boards (DOIT boards) and both show the exact same behaviour. With v3.0 of the ESP-IDF, I can happily flash and reset the boards multiple times, and the WiFi comes up very quickly and without error or fault, with or without a USB cable attached.

With v3.1, I can only get reliable WiFi if the USB cable is left unattached. Sometimes, if attached, it will come up after a power cycle, but it will not connect after a reset, and if left for a few minutes it drops out and tries to reconnect. About the only thing I can do to get a persistent connection is to leave the USB cable entirely disconnected, which makes it very difficult to develop on.

I have tried different USB cables too.

So it seems to be the change from v3.0 to v3.1 that has broken WiFi for me on these boards.

User avatar
brp80000
Posts: 115
Joined: Thu Oct 04, 2018 7:13 pm

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby brp80000 » Wed Feb 27, 2019 12:06 pm

new adventure. When connected to the iPhone code hangs on meditation guru. With Android clients everything works. I did not expect such instability from ESP in terms of WiFi connection. Little by little my project will be to change to another chip, but I think the strawberry Pi. I think to try whether IDF 3.1.3 or still something will fall off in this poor processor

User avatar
brp80000
Posts: 115
Joined: Thu Oct 04, 2018 7:13 pm

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby brp80000 » Wed Feb 27, 2019 3:45 pm

I will remind you I did not receive the ip address of the device with Android and I installed commit . After that, everything worked with Android, but IOS a tested only now. At the same time when you connect with Android still works, there is no meditation guru. The watchdog is set for 10 seconds and can not work for 1 second, but something goes wrong.What other surprises are coming to life?
  • Guru Meditation Error: Core 0 panic'ed (Interrupt wdt timeout on CPU0)
    Core 0 register dump:
    PC : 0x4013ba0a PS : 0x00060034 A0 : 0x8008bc90 A1 : 0x3ffbefa0
    A2 : 0x00000020 A3 : 0x00000000 A4 : 0x3ffb4d60 A5 : 0x3ffb2464
    A6 : 0x3ffb5088 A7 : 0x3ffb4e30 A8 : 0x3ffb4d7c A9 : 0x3ffbef80
    A10 : 0x00000000 A11 : 0x7fffffff A12 : 0x8008c928 A13 : 0x3ffbeea0
    A14 : 0x00000003 A15 : 0x00060023 SAR : 0x00000000 EXCCAUSE: 0x00000005
    EXCVADDR: 0x00000000 LBEG : 0x00000000 LEND : 0x00000000 LCOUNT : 0x00000000

    Backtrace: 0x4013ba0a:0x3ffbefa0 0x4008bc8d:0x3ffbefc0

    Core 1 register dump:
    PC : 0x4000c271 PS : 0x00060034 A0 : 0x8008c082 A1 : 0x3ffc3130
    A2 : 0x3ffc121c A3 : 0x3f4033ee A4 : 0x00000014 A5 : 0x3ffb1fc8
    A6 : 0x3ffb2010 A7 : 0x00000001 A8 : 0x00000001 A9 : 0x3f4033ef
    A10 : 0x000000a5 A11 : 0x00060023 A12 : 0x00060023 A13 : 0x00000001
    A14 : 0x0000abab A15 : 0x00000000 SAR : 0x0000001f EXCCAUSE: 0x00000005
    EXCVADDR: 0x00000000 LBEG : 0x4000c2e0 LEND : 0x4000c2f6 LCOUNT : 0x0000001a

    Backtrace: 0x4000c271:0x3ffc3130 0x4008c07f:0x3ffc3150 0x4008d360:0x3ffc3180 0x4008d316:0x3ffba454

    CPU halted.

meowsqueak
Posts: 136
Joined: Thu Jun 15, 2017 4:54 am
Location: New Zealand

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby meowsqueak » Wed Feb 27, 2019 8:17 pm

No offense brp80000 but you've already hijacked this thread once - please don't do it again.

Can you please create another thread for your own issue? Your symptoms are unrelated to mine and it's just confusing the issue I'm trying to pin down.

littlesky
Posts: 47
Joined: Fri Jun 09, 2017 7:49 am

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby littlesky » Thu Feb 28, 2019 2:36 am

Please create a GitHub issue for this. Someone else will help you.

littlesky
Posts: 47
Joined: Fri Jun 09, 2017 7:49 am

Re: v3.0 to v3.1 migration guide? WiFi not working...

Postby littlesky » Thu Feb 28, 2019 11:39 am

brp80000 wrote:
Wed Feb 27, 2019 3:45 pm
I will remind you I did not receive the ip address of the device with Android and I installed commit . After that, everything worked with Android, but IOS a tested only now. At the same time when you connect with Android still works, there is no meditation guru. The watchdog is set for 10 seconds and can not work for 1 second, but something goes wrong.What other surprises are coming to life?
  • Guru Meditation Error: Core 0 panic'ed (Interrupt wdt timeout on CPU0)
    Core 0 register dump:
    PC : 0x4013ba0a PS : 0x00060034 A0 : 0x8008bc90 A1 : 0x3ffbefa0
    A2 : 0x00000020 A3 : 0x00000000 A4 : 0x3ffb4d60 A5 : 0x3ffb2464
    A6 : 0x3ffb5088 A7 : 0x3ffb4e30 A8 : 0x3ffb4d7c A9 : 0x3ffbef80
    A10 : 0x00000000 A11 : 0x7fffffff A12 : 0x8008c928 A13 : 0x3ffbeea0
    A14 : 0x00000003 A15 : 0x00060023 SAR : 0x00000000 EXCCAUSE: 0x00000005
    EXCVADDR: 0x00000000 LBEG : 0x00000000 LEND : 0x00000000 LCOUNT : 0x00000000

    Backtrace: 0x4013ba0a:0x3ffbefa0 0x4008bc8d:0x3ffbefc0

    Core 1 register dump:
    PC : 0x4000c271 PS : 0x00060034 A0 : 0x8008c082 A1 : 0x3ffc3130
    A2 : 0x3ffc121c A3 : 0x3f4033ee A4 : 0x00000014 A5 : 0x3ffb1fc8
    A6 : 0x3ffb2010 A7 : 0x00000001 A8 : 0x00000001 A9 : 0x3f4033ef
    A10 : 0x000000a5 A11 : 0x00060023 A12 : 0x00060023 A13 : 0x00000001
    A14 : 0x0000abab A15 : 0x00000000 SAR : 0x0000001f EXCCAUSE: 0x00000005
    EXCVADDR: 0x00000000 LBEG : 0x4000c2e0 LEND : 0x4000c2f6 LCOUNT : 0x0000001a

    Backtrace: 0x4000c271:0x3ffc3130 0x4008c07f:0x3ffc3150 0x4008d360:0x3ffc3180 0x4008d316:0x3ffba454

    CPU halted.
Can you provide the whole log?

Who is online

Users browsing this forum: No registered users and 21 guests