Issue with the esp-idf/make/project.mk

ajaymm58
Posts: 12
Joined: Fri Jan 29, 2016 6:02 pm

Issue with the esp-idf/make/project.mk

Postby ajaymm58 » Sat Jan 14, 2017 8:58 pm

With the latest SDK and tools, I noticed the following issue:
At Line #432 and #433, the toolchain version verification returns a null string.
TOOLCHAIN_COMMIT_DESC := $(shell $(CC) --version | sed -E -n 's|xtensa-esp32-elf-gcc\ \(([^)]*).*|\1|gp')
TOOLCHAIN_GCC_VER := $(shell $(CC) --version | sed -E -n 's|xtensa-esp32-elf-gcc\ \(.*\)\ (.*)|\1|gp')

I think that they need to contain ".exe" in the filename:
TOOLCHAIN_COMMIT_DESC := $(shell $(CC) --version | sed -E -n 's|xtensa-esp32-elf-gcc.exe\ \(([^)]*).*|\1|gp')
TOOLCHAIN_GCC_VER := $(shell $(CC) --version | sed -E -n 's|xtensa-esp32-elf-gcc.exe\ \(.*\)\ (.*)|\1|gp')

I use MSYS release from:
https://dl.espressif.com/dl/esp32_win32 ... 170111.zip

I get error as follows:
$ make menuconfig
WARNING: Toolchain version is not supported:
Expected to see version: crosstool-NG crosstool-ng-1.22.0-61-gab8375a
Please check ESP-IDF setup instructions and update the toolchain, or proceed at your own risk.
/c/projects/esp32/esp-idf/make/project.mk:445: WARNING: Compiler version is not supported:
Expected to see version(s): 5.2.0
Please check ESP-IDF setup instructions and update the toolchain, or proceed at your own risk.
MENUCONFIG

WiFive
Posts: 3078
Joined: Tue Dec 01, 2015 7:35 am

Re: Issue with the esp-idf/make/project.mk

Postby WiFive » Sun Jan 15, 2017 5:38 am


Who is online

Users browsing this forum: Baidu [Spider], kristaps_r, MikeLemon and 65 guests