SPI no longer working to radio on TTGO LoRa OLED v1

ecc esp
Posts: 8
Joined: Mon Jan 28, 2019 10:18 pm

SPI no longer working to radio on TTGO LoRa OLED v1

Postby ecc esp » Fri Mar 13, 2020 10:01 pm

I've written a project that uses the radio (RFM95 / SX1276) on the TTGO LoRa OLED v1 module. I developed it with the 4.1-dev branch of ESP-IDF about 6 months ago. The project is here: https://github.com/ecc1/gnarl

I got it working reasonably well and just revisited it. I installed a fresh ESP-IDF release_v4.1 environment and it no longer works. The low-level SPI reads and writes to the radio's registers are not working as expected. (The program in src/regtest/main.c is the simplest example of how it fails.)

I also tried using the Arduino IDE instead of ESP-IDF, with a simple read_register program, and tried the code here https://randomnerdtutorials.com/ttgo-lo ... duino-ide/ , all of which fail.

Something has bit-rotted but I couldn't manage to make things work by reverting to older versions of ESP-IDF either.

Any pointers or suggestions about what to try next would be appreciated.

Who is online

Users browsing this forum: No registered users and 4 guests