开发环境搭建错误

duran_D
Posts: 1
Joined: Sun Aug 16, 2020 2:35 am

开发环境搭建错误

Postby duran_D » Sun Aug 16, 2020 2:40 am

开始报错

Code: Select all

$ make meunconfig
The following Python requirements are not satisfied:
click>=5.0
pyelftools>=0.22
esp-windows-curses; sys_platform == 'win32'
The recommended way to install a packages is via "pacman". Please run "pacman -Ss <package  _name>" for searching the package database and if found then "pacman -S mingw-w64-i686-pyt  hon-<package_name>" for installing it.
NOTE: You may need to run "pacman -Syu" if your package database is older and run twice if   the previous run updated "pacman" itself.
Please read https://github.com/msys2/msys2/wiki/Using-packages for further information abo  ut using "pacman"
make: *** 没有规则可制作目标“meunconfig”。 停止。
运行pacman -Syu进行更新

Code: Select all

$ pacman -Syu
:: 正在同步软件包数据库...
 mingw32                       518.5 KiB  12.8K/s 00:40 [############################] 100%
 mingw32.sig                   438.0   B  0.00B/s 00:00 [############################] 100%
错误:GPGME 错误:System error w/o errno
错误:无法升级 mingw32 (无效或已损坏的数据库 (PGP 签名))
 mingw64                       520.2 KiB  10.9K/s 00:48 [############################] 100%
 mingw64.sig                   438.0   B  0.00B/s 00:00 [############################] 100%
错误:GPGME 错误:System error w/o errno
错误:无法升级 mingw64 (无效或已损坏的数据库 (PGP 签名))
 msys                          184.2 KiB  13.3K/s 00:14 [############################] 100%
 msys.sig                      438.0   B  0.00B/s 00:00 [############################] 100%
错误:GPGME 错误:System error w/o errno
错误:无法升级 msys (无效或已损坏的数据库 (PGP 签名))
错误:同步所有数据库失败
这样该如何处理,谢谢。

Who is online

Users browsing this forum: No registered users and 10 guests