Arduino Env. and ESP wrover

Gunter H
Posts: 3
Joined: Mon Jul 17, 2017 11:31 am

Arduino Env. and ESP wrover

Postby Gunter H » Mon Jul 17, 2017 11:48 am

Hello,

Environment:
ESP32 wrover (dev board) / ESP32 wroom / working arduino environment on Win7/64 bit.

Symtoms:
Script flased on a ESP32 wroom are executed (for example simple blink)
Scripts can be flashed on ESP wrover module, but seems not to be executed (no blinking led :( .

IDF_SDK blink sample runs on ESP32 wrover.

Question:
Is the flash speed set via arduno bootloader always set to 80MHz?
As I read in an other thread, flash speed of 80 MHz causes trouble on dev board.

If yes, can bootloader used by arduino environment be modified (patched)?

thanks in advance,
Gunter

f.h-f.s.
Posts: 178
Joined: Thu Dec 08, 2016 2:53 pm

Re: Arduino Env. and ESP wrover

Postby f.h-f.s. » Mon Jul 17, 2017 2:57 pm

I think the 80mhz in bootloader means the CPU Clock.
The problems with 80mhz is when the SPI connected PSRAM is clocked at 80mhz. (or so i've read)

Gunter H
Posts: 3
Joined: Mon Jul 17, 2017 11:31 am

Re: Arduino Env. and ESP wrover

Postby Gunter H » Tue Jul 18, 2017 9:10 am

Found it by myself...Just set 40MHz in Tools...Flash frequency...

copercini
Posts: 13
Joined: Wed Dec 21, 2016 4:44 pm

Re: Arduino Env. and ESP wrover

Postby copercini » Wed Jul 19, 2017 8:03 pm

Gunter H wrote:Is the flash speed set via arduno bootloader always set to 80MHz?

You can set in on Arduino menu
Image

I also heard that the flash of wrover (module) doesn't work in 80Mhz

Who is online

Users browsing this forum: No registered users and 5 guests