Problem uploading code

Five_O
Posts: 3
Joined: Wed Apr 24, 2019 11:06 am

Problem uploading code

Postby Five_O » Wed Apr 24, 2019 11:16 am

Hi,

I have problem uploading first code. I have tried different upload speeds. All divers and Arduino IDE are updated.

After upload, tried with boot button and without it, even with capacitor mod, same case:

Build options changed, rebuilding all
Sketch uses 194472 bytes (14%) of program storage space. Maximum is 1310720 bytes.
Global variables use 13332 bytes (4%) of dynamic memory, leaving 314348 bytes for local variables. Maximum is 327680 bytes.
esptool.py v2.6
Serial port COM3
Connecting........____
Chip is ESP32D0WDQ6 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
MAC: ****************
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Warning: Could not auto-detect Flash size (FlashID=0x0, SizeID=0x0), defaulting to 4MB
Compressed 8192 bytes to 47...

Writing at 0x0000e000... (100 %)
Wrote 8192 bytes (47 compressed) at 0x0000e000 in 0.0 seconds (effective 4096.0 kbit/s)...

A fatal error occurred: Timed out waiting for packet header
A fatal error occurred: Timed out waiting for packet header

In serial open and boot button:

ets Jun 8 2016 00:22:57

rst:0x10 (RTCWDT_RTC_RESET),boot:0x1 (DOWNLOAD_BOOT(UART0/UART1/SDIO_FEI_REO_V2))
waiting for download

Only thing different for similar problem is boot code boot:0x1 ? What it means?

idahowalker
Posts: 96
Joined: Wed Aug 01, 2018 12:06 pm

Re: Problem uploading code

Postby idahowalker » Wed Apr 24, 2019 8:01 pm

Did you try, after the start of upload code, holding down the EN button?

I use a powered hub between the computer and the ESP32, since adding a powered USB hub issues like needing to hold down this button or that button have went away. The is also another reason to use some kind of isolator between your computer and the ESP32 and that is that the ESP32 can feed power from your project into your computer.

There are also USB isolators (
HiLetgo ADUM3160 B0505S 1500V USB to USB Voltage Isolator Module Support 12Mbps 1.5Mbps https://smile.amazon.com/HiLetgo-ADUM31 ... way&sr=8-5 that may work. I've not tried them.

Five_O
Posts: 3
Joined: Wed Apr 24, 2019 11:06 am

Re: Problem uploading code

Postby Five_O » Thu Apr 25, 2019 4:19 pm

Yes I have tried. I think all combinations :D Today I tried with new short USB cable. Nothing seems to work.

Who is online

Users browsing this forum: Bing [Bot] and 8 guests