BOOT: to press or not to press.

stamasd
Posts: 7
Joined: Sun May 26, 2019 12:24 pm

BOOT: to press or not to press.

Postby stamasd » Sat Jun 08, 2019 12:37 am

Not a big issue, but I noticed something strange with the ESP32 Devkit V1. I develop on my laptop which is dual-boot (Windows and Linux). Using Arduino v.1.8.9 on both.

When I develop in Linux and compile/upload a sketch, I don't have to press BOOT on the ESP32 board to upload.
When I develop in Windows, I do need to press BOOT for the upload to complete or else it fails.
This of course happens with the same board, same computer, same cable etc - only the OS is different.

Just curious why this happens.

User avatar
krzychb
Posts: 227
Joined: Sat Oct 01, 2016 9:05 am
Contact:

Re: BOOT: to press or not to press.

Postby krzychb » Sat Jun 08, 2019 2:03 am

Hi stamasd,

I see you are using V1 version of ESP32-DevKitC. This is fairly old version and I believe related description and fix specific for Windows is covered in https://github.com/espressif/esptool/issues/136.

Try adding a capacitor as discussed in this issue report and the issue will likely be resolved.

stamasd
Posts: 7
Joined: Sun May 26, 2019 12:24 pm

Re: BOOT: to press or not to press.

Postby stamasd » Sat Jun 08, 2019 9:41 am

Thank you for the reply. Like I said it's not a major issue and I don't mind pressing the button if I have to. I was just curious why the behavior is different on the 2 operating systems. That thread explained it. Thanks again.

Who is online

Users browsing this forum: No registered users and 4 guests