Use VS Code Arduino plugin with ESP32

ahue32
Posts: 16
Joined: Mon Nov 06, 2017 10:09 am

Use VS Code Arduino plugin with ESP32

Postby ahue32 » Thu Jan 18, 2018 9:16 am

Hello,

I am trying to use Visual Studio Code to program my Adafruit HUZZAH32 Feather. The problem is, that it is impossible for me to select the right board type. I managed to install the esp8266 package via board manager and tried to put the path to the json of esp32 in the settings:

Code: Select all

    "arduino.path": "C:\\Users\\me\\Desktop\\arduino-1.8.4",
    "workbench.panel.location": "right",
    "http.proxy": ,
    "arduino.additionalUrls": [
        "https://github.com/espressif/arduino-esp32/blob/master/package/package_esp32_index.template.json"
    ],
    "window.zoomLevel": 0
You can follow the link to see what it looks like.


However, when I click "refresh package indexes", the file gets changed to this:

Code: Select all

<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
  <link rel="dns-prefetch" href="https://assets-cdn.github.com">
  <link rel="dns-prefetch" href="https://avatars0.githubusercontent.com">
  <link rel="dns-prefetch" href="https://avatars1.githubusercontent.com">
  <link rel="dns-prefetch" href="https://avatars2.githubusercontent.com">
  <link rel="dns-prefetch" href="https://avatars3.githubusercontent.com">
  <link rel="dns-prefetch" href="https://github-cloud.s3.amazonaws.com">
  <link rel="dns-prefetch" href="https://user-images.githubusercontent.com/">



  <link crossorigin="anonymous" href="https://assets-cdn.github.com/assets/frameworks-63d382b7c748b0ca1b0b8772c6ac07942f39a78775d4716abded6fb8d6d8e544845848ef5f69e923c6e897cace3a187cd55e75ef1f78a58dd410b2e609b6673a.css" media="all" rel="stylesheet" />
  <link crossorigin="anonymous" href="https://assets-cdn.github.com/assets/github-dfc641ae3814dd7e98f0ee03849c90dccb4f6da08c9591721b39cb78a06a863e1bab047076761abb4ff0c143bfcf02c54f43c4a087142f110ff002b9f04bd0f1.css" media="all" rel="stylesheet" />
  
  
  <link crossorigin="anonymous" href="https://assets-cdn.github.com/assets/site-7f35718b16060ae00fcabab9480872c8a8b09434e780d16432395e8b809142b82a36abe0a936f4cb1b56452e1e81cac5f197beaf0cbdbd149dc5d87d0514076a.css" media="all" rel="stylesheet" />
  

  <meta name="viewport" content="width=device-width">
  
  <title>arduino-esp32/package_esp32_index.template.json at master · espressif/arduino-esp32 · GitHub</title>
  <link rel="search" type="application/opensearchdescription+xml" href="/opensearch.xml" title="GitHub">
  <link rel="fluid-icon" href="https://github.com/fluidicon.png" title="GitHub">
  <meta property="fb:app_id" content="1401488693436528">

    
    <meta content="https://avatars3.githubusercontent.com/u/9460735?s=400&v=4" property="og:image" /><meta content="GitHub" property="og:site_name" /><meta content="object" property="og:type" /><meta content="espressif/arduino-esp32" property="og:title" /><meta content="https://github.com/espressif/arduino-esp32" property="og:url" /><meta content="arduino-esp32 - Arduino core for the ESP32" property="og:description" />

[.....]

  </body>
</html>

and I get the following error:

Code: Select all

Ausgew�hltes Board ist nicht verf�gbar
Picked up _JAVA_OPTIONS: -Djava.net.preferIPv4Stack=true
[Done] Updated package index files.
[Error] Invalid json file "C:\Users\HUA1WA3\AppData\Local\Arduino15\package_esp32_index.template.json".
            Suggest to remove it manually and allow boardmanager to re-download it.
[Error] Invalid json file "C:\Users\HUA1WA3\AppData\Local\Arduino15\package_esp32_index.template.json".
            Suggest to remove it manually and allow boardmanager to re-download it.
I can then change the file manually and the package appears in the board manager, but the "install" button is not clickable. Can anyone help?

Who is online

Users browsing this forum: No registered users and 13 guests