How to install old idf version ?

Agree007
Posts: 44
Joined: Mon Sep 18, 2017 7:11 pm
Location: Copenhagen

How to install old idf version ?

Postby Agree007 » Mon Aug 20, 2018 9:25 am

As I have different problems after upgrading to the latest version (output from esp_get_idf_version() ) v3.2-dev-39-gaff12390
I would like to install old version v3.1-dev-662-gf586f5e5 , but as I have not been able to find any information on how to install older versions, I hope some knows how to do it ?

FYI - the issues I have with the new version, is related to memory usage (I can not use same array size) and wifi (get to many event for the same event id (seems to loop) and problems with reconnect) - I did NOT have any of these issues with the old version, thats why I want to reinstall the old version ;)

Thx in advance for your support.

Cut from serial monitor ( 01) START WIFI just call WiFi.begin(ssid, pass); ) :

01) START_WIFI
SYSTEM_EVENT_STA_STOP
SYSTEM_EVENT_STA_STOP
SYSTEM_EVENT_WIFI_READY
SYSTEM_EVENT_STA_START
E (723045) wifi: esf_buf: t=3 l=32 max:8, alloc:8 no eb
SYSTEM_EVENT_WIFI_READY
SYSTEM_EVENT_STA_START
SYSTEM_EVENT_STA_START
SYSTEM_EVENT_STA_START
E (734353) wifi: esf_buf: t=3 l=32 max:8, alloc:8 no eb
SYSTEM_EVENT_WIFI_READY
SYSTEM_EVENT_STA_START
SYSTEM_EVENT_STA_START
SYSTEM_EVENT_STA_START
E (735483) wifi: esf_buf: t=3 l=32 max:8, alloc:8 no eb
SYSTEM_EVENT_WIFI_READY
SYSTEM_EVENT_STA_START
SYSTEM_EVENT_STA_START
SYSTEM_EVENT_STA_START
E (736614) wifi: esf_buf: t=3 l=32 max:8, alloc:8 no eb
SYSTEM_EVENT_WIFI_READY
SYSTEM_EVENT_STA_START
SYSTEM_EVENT_STA_START
SYSTEM_EVENT_STA_START

ESP_igrr
Posts: 1596
Joined: Tue Dec 01, 2015 8:37 am

Re: How to install old idf version ?

Postby ESP_igrr » Mon Aug 20, 2018 2:55 pm

The part after "g" in "v3.1-dev-662-gf586f5e5" is the short git commit ID. You can use it along with "git checkout" command. Don't forget to update the submodules.

git checkout f586f5e5
git submodule update

Agree007
Posts: 44
Joined: Mon Sep 18, 2017 7:11 pm
Location: Copenhagen

Re: How to install old idf version ?

Postby Agree007 » Mon Aug 20, 2018 3:40 pm

Thanks, I will try figure out :o where to add and/or change the below commands, so I get the correct version

sudo usermod -a -G dialout $USER && \
sudo apt-get install git && \
wget https://bootstrap.pypa.io/get-pip.py && \
sudo python get-pip.py && \
sudo pip install pyserial && \
mkdir -p ~/Arduino/hardware/espressif && \
cd ~/Arduino/hardware/espressif && \
git clone https://github.com/espressif/arduino-esp32.git esp32 && \
cd esp32 && \
git submodule update --init --recursive && \
cd tools && \
python2 get.py

Agree007
Posts: 44
Joined: Mon Sep 18, 2017 7:11 pm
Location: Copenhagen

Re: How to install old idf version ?

Postby Agree007 » Mon Aug 20, 2018 5:45 pm

ESP_igrr wrote: git checkout f586f5e5
I am new to all the Git stuff, but I am running Linux and when I run the command "git checkout f586f5e5" it does not find f586f5e5 , so there must be something missing or I am doing it wrong, so hope someone can list the command I should use to install the commit id f586f5e5 in Arduino ide when running Linux ?

Thansk again for any support you can give me :D

User avatar
kolban
Posts: 1683
Joined: Mon Nov 16, 2015 4:43 pm
Location: Texas, USA

Re: How to install old idf version ?

Postby kolban » Mon Aug 20, 2018 10:31 pm

Howdy,
This may be a complete red-herring ... but I wanted to check that you understand the distinction between releases and master. As I understand it, the "master" on Github is the continually evolving "best so far" of the ESP-IDF code base. Things may break and stability may not be perfect. Releases are points in time snapshots of the master code base where (I presume) extensive testing has been performed and we can all agree on its content. If we visit the ESP-IDF GitHub page and look at the "branches" we see the releases available. These include "release/v3.0" and "release/v3.1" ... as well as "master".

Might you want to stick with a release version?

If so the recipe would be:

$ git clone https://github.com/espressif/esp-idf.git
$ cd esp-idf
$ git checkout "release/v3.1"

This would then mean you are using that specific version.

I also note that despite the "tag" "release/v3.1", the latest stable release is "v3.0.3" so I would go with "release/v3.0".

In addition, you can download the whole release from the Github releases pages as a ZIP file which might be an alternative story for you.

See:

https://github.com/espressif/esp-idf/releases
Free book on ESP32 available here: https://leanpub.com/kolban-ESP32

Agree007
Posts: 44
Joined: Mon Sep 18, 2017 7:11 pm
Location: Copenhagen

Re: How to install old idf version ?

Postby Agree007 » Tue Aug 21, 2018 6:09 am

Thanks Kolban, I am still learning ;)

When I look at "https://github.com/espressif/arduino-esp32" there is only one (1) Branch, the "master" , so not sure I can use your suggestion, but I will give it a try later.

I am moving from using from Arduino to Clion using esp-idf - but still have one large project which is not moved and that the one giving me these problems after I reinstalled Arduino and ESP32 on Linux.

I just found that I still have the old 'version' (Arduino & esp32) install on an old windows pc, so I might have to use that for this project until I got the time to move it.

Who is online

Users browsing this forum: No registered users and 24 guests