Automatic upload only working on some boards

idahowalker
Posts: 96
Joined: Wed Aug 01, 2018 12:06 pm

Automatic upload only working on some boards

Postby idahowalker » Thu Dec 13, 2018 6:31 pm

ESP32-a and ESP32-b.

ESP32-a plugged in via USB takes, from the Arduino IDE, a upload with no problem.

ESP32-b, takes an upload only if I, during the connection point of the upload, press and hold for a moment, both buttons.

Why is that?

What could be done to ESP32-b to have it work like ESP32-a?

f.h-f.s.
Posts: 208
Joined: Thu Dec 08, 2016 2:53 pm

Re: Why is that?

Postby f.h-f.s. » Mon Dec 17, 2018 4:21 pm

It has to do with the bootmode of the board. See:
https://github.com/espressif/esptool/wi ... bootloader
esptool.py can automatically enter the bootloader on many boards by using the RTS and DTR modem status lines to toggle GPIO0 and EN automatically.
Development boards (including all Espressif boards) usually use additional circuitry to avoid this problem - if both RTS and DTR are both asserted together, this doesn't reset the chip. Consult Espressif development board schematics for the specific details.

ESP_Angus
Posts: 1812
Joined: Sun May 08, 2016 4:11 am

Re: Automatic upload only working on some boards

Postby ESP_Angus » Tue Dec 18, 2018 3:35 am

I've renamed the topic of the post to give some more details.

What models are the two boards? Some third party boards (and very old Espressif boards) can have more reliable auto-reset if a capacitor is added between the EN pin and GND (something in the 1uF-10uF range should work).

Who is online

Users browsing this forum: Google [Bot] and 11 guests