ESP-WROOM-32 AT commands firmware

klteng
Posts: 8
Joined: Sat Feb 25, 2017 4:15 pm

Re: ESP-WROOM-32 AT commands firmware

Postby klteng » Sat Feb 25, 2017 4:24 pm

I tried to follow the steps to flash the ESP32-AT but seem doesn't work. I am quite confuse on the UART1 Tx and Rx pin number. Which pin number does it refer to? Is it the UART1 pin number on the ESP32 chipset?

Is there any full instruction on flashing the ESP32-AT and able to work?

User avatar
rudi ;-)
Posts: 1517
Joined: Fri Nov 13, 2015 3:25 pm

Re: ESP-WROOM-32 AT commands firmware

Postby rudi ;-) » Mon Feb 27, 2017 10:33 am

klteng wrote:I tried to follow the steps to flash the ESP32-AT but seem doesn't work.
.. I am quite confuse on the UART1 Tx and Rx pin number.
Which pin number does it refer to?
Is it the UART1 pin number on the ESP32 chipset?
Is there any full instruction on flashing the ESP32-AT and able to work?
hi
it work's fantastic :)
chaning from
UART1 Tx
UART1 Rx
to UART0
uart_choice.png
uart_choice.png (22.65 KiB) Viewed 5864 times
pin list are here
http://espressif.com/sites/default/file ... ist_en.pdf

short view:
uarts.png
uarts.png (82.03 KiB) Viewed 5864 times
and you can use your own pins, that you have to select then in component config -> AT

hope this helps
best wishes
rudi ;-)
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

wind_energy
Posts: 28
Joined: Fri Feb 03, 2017 10:36 pm

Re: ESP-WROOM-32 AT commands firmware

Postby wind_energy » Tue Feb 28, 2017 7:27 am

hi,

If there is any solution to refresh joined devices IP? When I`m using AT+CWLIF as soon as I connect to station my smartphone it display IP address but it still appears whenever the smartphone is disconected.

Code: Select all

ready
AT

OK
AT+CWMODE=3

OK
AT+CWDHCP=1,1

OK
AT+CWSAP="ESP_MAIN_W","",10,0

OK
AT+CWSAP?
+CWSAP:"ESP_MAIN_W","",10,0,10,0

OK
AT+CWLIF

OK
AT+CWLIF

OK
AT+CWLIF

OK
AT+CWLIF

OK
AT+CWLIF
0.0.0.0,5c:af:06:45:e0:21

OK
AT+CWLIF
0.0.0.0,5c:af:06:45:e0:21

OK
AT+CWLIF
0.0.0.0,5c:af:06:45:e0:21

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK
AT+CWLIF    // here I`m disconected first time it works OK

OK
AT+CWLIF

OK
AT+CWLIF

OK
AT+CWLIF

OK
AT+CWLIF

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21 // conected again

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21 // disconected 

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21 // still apears IP of the smartphone

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK
AT+CWLIF
192.168.4.2,5c:af:06:45:e0:21

OK

Many thanks for any ideas :)

wind_energy
Posts: 28
Joined: Fri Feb 03, 2017 10:36 pm

Re: ESP-WROOM-32 AT commands firmware

Postby wind_energy » Tue Feb 28, 2017 7:33 am

I have another problem and I don`t have any idea what I`m doing wrong. I can`t conect to the STATION from another ESP32 configured as a CLIENT.

STATION

Code: Select all

ready
AT

OK
AT+CWMODE=3

OK
AT+CWDHCP=1,1

OK
AT+CWSAP="ESP_MAIN_W","",10,0

OK
AT+CWSAP?
+CWSAP:"ESP_MAIN_W","",10,0,10,0

OK
CLIENT

Code: Select all

AT

OK
AT+CWMODE=1

OK
AT+CWDHCP=1,1

OK

AT+CWLAP
+CWLAP:(0,"ESP_MAIN_W",-31,"24:0a:c4:02:ed:99",10)

OK
AT+CWJAP="ESP_MAIN_W","",

ERROR

Regards,
Pawel

User avatar
rudi ;-)
Posts: 1517
Joined: Fri Nov 13, 2015 3:25 pm

Re: ESP-WROOM-32 AT commands firmware

Postby rudi ;-) » Tue Feb 28, 2017 1:05 pm

hi pawel,

i am on the road just in time
see on first view a mistake last character

AT+CWJAP="ESP_MAIN_W","",

try without the last

AT+CWJAP="ESP_MAIN_W",""

cause you use no pwd
try this too

AT+CWJAP="ESP_MAIN_W"

let me know

best wishes
rudi ;-)
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

wind_energy
Posts: 28
Joined: Fri Feb 03, 2017 10:36 pm

Re: ESP-WROOM-32 AT commands firmware

Postby wind_energy » Tue Feb 28, 2017 2:26 pm

hi rudi,

When I`m using the terminal, everything works better.

Code: Select all

AT+CWJAP="ESP_MAIN_W",""

OK
AT+CIPMUX=0

OK
AT+CIPSTART="UDP","192.168.4.1",909,909,0
CONNECT

OK

+IPD,7:wertyui
+IPD,7:wertyui

AT+CIPSEND=7

OK

>
Recv 7 bytes

SEND FAIL
AT+CIPSEND=7

OK

>
Recv 7 bytes

SEND FAIL  // SEND FAIL, why?? receiving works good, transmitting occurs the fail reports
AT+CIPSEND=7

OK

>
busy p...

Recv 7 bytes

SEND FAIL
AT+CIPSEND=7

OK

>
Recv 7 bytes

SEND FAIL

+IPD,7:wertyuiCLOSED
AT+CIPSTART="UDP","192.168.4.1",909,909,0
CONNECT

OK
AT+CIPSEND=7

OK

>
Recv 7 bytes

SEND FAIL
AT+CIPSEND=7

OK

>
Recv 7 bytes

SEND FAIL

+IPD,7:wertyuiCLOSED
When I`m using the AVR couple of things dosen`t work properly.

Most times I`m loosing the reception. Can`t find SSID name of the station on my celphone and another ESP32 modules.
As soon as I make communication through the terminal, most things works better. I`ve added the low ESR capacitor of 3300uF and ceramic 100nF but it doesn`t fix the problems.
I enclousure the picture of soldered modules.
Attachments
20170228_152013.jpg
20170228_152013.jpg (2.55 MiB) Viewed 5842 times

User avatar
rudi ;-)
Posts: 1517
Joined: Fri Nov 13, 2015 3:25 pm

Re: ESP-WROOM-32 AT commands firmware

Postby rudi ;-) » Tue Feb 28, 2017 5:42 pm

hi pawel
how looks your line in AVR to send msg over UART to esp?

AVR_Uart_printf("AT+.......\r\n");

how you send the "

best wishes
rudi ;-)
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

wind_energy
Posts: 28
Joined: Fri Feb 03, 2017 10:36 pm

Re: ESP-WROOM-32 AT commands firmware

Postby wind_energy » Tue Feb 28, 2017 7:40 pm

I`ve changed the ground and 9600 baudrate - at the moment works brilliant :D

Luca_Guazzaroni
Posts: 4
Joined: Thu Feb 23, 2017 1:12 pm

Re: ESP-WROOM-32 AT commands firmware

Postby Luca_Guazzaroni » Wed Mar 01, 2017 11:35 am

Hello Rudi! thank you very much for your help.

In my las post i wrote twice that i've used the uart1. Actually in the second time i used the uart0 just like you do it.
Component Config -> AT (using a usb-serial adapter)
*uart port number for AT command = 0
*uart rx pin for AT command = 3
*uart tx pin for AT command = 1
After reading your answer, i tried using the same serial program with the same configuration that you use.
and also not works :(

Can you send me your bin files? to check if i am making some mistake at compilation or is another problem.

regards

Luca_Guazzaroni
Posts: 4
Joined: Thu Feb 23, 2017 1:12 pm

Re: ESP-WROOM-32 AT commands firmware

Postby Luca_Guazzaroni » Wed Mar 01, 2017 2:45 pm

I think that the problem is the version of the esp-idf and esp-at-master example. the monitor console shows me:
E (1826) wifi: esp_wifi_set_storage 1230 wifi is not init
W (1832) wifi: wifi nvs_open fail ret=4353

E (1835) wifi: wifi_init 1191 ret=4353
assertion "0 && "esp_wifi_init(&cfg)"" failed: file "/home/xcg/workspace/esp_iot_at/esp-at-application/components/esp-at-core/./at_port.c", line 560, function: initialise_wifi
abort() was called at PC 0x400f732f
Guru Meditation Error: Core 0 panic'ed (abort)
And from what i could read in https://github.com/espressif/esp32-at/issues/6 and https://github.com/espressif/esp-idf/co ... a27e5bbdc7, a update may cause the problem. That's right?

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot] and 30 guests