[BUG] Custom Bootloader in Projektfolder is no longer considered ? Release V3.3, v3.2..

ESP_Angus
Posts: 1813
Joined: Sun May 08, 2016 4:11 am

Re: [BUG] Custom Bootloader in Projektfolder is no longer considered ? Release V3.3, v3.2..

Postby ESP_Angus » Tue Sep 17, 2019 12:02 am

Hi rudi,
rudi ;-) wrote:
Mon Sep 16, 2019 8:07 pm
ok i noted in few postings, that more the more cmake is used and GNU Make is supported only do v4.x.
i read, the existing GNU Make based build system will be deprecated in ESP-IDF V5.0.
That's right. We don't have a release date for ESP-IDF V5.0 yet (we haven't even released V4.0), but V4.x will be supported for many years to come - including the GNU Make build system support.
rudi ;-) wrote:
Mon Sep 16, 2019 8:07 pm
(only cmake) eclipse plugin
One of the reasons we're moving to CMake is to allow better IDE support. Eclipse CDT also uses CMake so we can give a much more tightly integrated IDE experience - simpler setup, more features, faster builds, more reliable source inspection and debugging support.
rudi ;-) wrote:
Mon Sep 16, 2019 8:07 pm
Will it be an ESP32S2, ESP32S3, ESP32S4 GNU Make Version
New chip support in ESP-IDF will be for CMake build system only. Adding multiple chip target support to the GNU Make build system was difficult so this has only been done for CMake.
rudi ;-) wrote:
Mon Sep 16, 2019 8:07 pm
32bit Windows version then no longer give? Not at all?
So I understood it now, it must necessarily be installed on 64bit Windows because CMAKE demands 64bit?
CMake supports 32-bit Windows. The limitation for us is that we also use the Ninja build tool by default and Ninja stopped releasing builds for 32-bit Windows in 2017.

When the ESP-IDF CMake preview was released last year we released an installer which bundles CMake and Ninja, so it was for 64-bit Windows only.

It's probably possible to make the CMake build system work on 32 bit Windows today, if you can find a 32-bit build of Ninja or install a different build tool that also works with CMake - for example Mingw32 Make. It may also be possible to run CMake under your existing MYS2 environment on Win32 if you install the CMake & Ninja packages into MSYS2. We haven't had the time and resources to test these different configs, though.

Our approach has been to start with supporting one config that we knew worked well (64-bit Windows using the installer and native CMake+Ninja). If there's a large number of users who need official 32-bit Windows support then we can look into ways to officially support that as well.
rudi ;-) wrote:
Mon Sep 16, 2019 8:07 pm
Also, the older GNU Make SDK must be deleted as I understood then.
You can install both on the same computer, no problems. The only thing to consider is if using the system environment variables to set toolchain paths, IDF_PATH etc. which are seen by all programs.

The solution is: When using the MSYS2 Unix-style environment for GNU Make then you can set these variables in the MSYS2 .profile or .bashrc file only, and they'll only be set to those values when using the MSYS2 Shell. Or when using Eclipse you can set them in the project. Either way allows you to have multiple totally independent SDK installations.

Who is online

Users browsing this forum: Bing [Bot], permal and 18 guests