Crash happen after connect AP long time

xzwang
Posts: 22
Joined: Wed Dec 14, 2016 4:54 am

Crash happen after connect AP long time

Postby xzwang » Tue Feb 21, 2017 1:17 am

Hi,all

I got a crash which seemed to be happened after connected AP for long time. ESP32 disconnected to AP, and print the log like that:
I (19830063) wifi: bcn_timout,ap_probe_send_start
I (19832563) wifi: ap_probe_send over, resett wifi status to disassoc
I (19832563) wifi: state: run -> init (1)
I (19832563) wifi: n:1 0, o:1 1, ap:255 255, sta:1 1, prof:1
I (19832563) wifi: pm stop, total sleep time: 0/-1656040326

It looks like the sleep time was overflowed ?
Anyone can give me some suggestion?
Thanks.

ESP_puff
Posts: 13
Joined: Tue Jan 10, 2017 8:34 am

Re: Crash happen after connect AP long time

Postby ESP_puff » Tue Feb 21, 2017 9:59 am

Hello xzwang,
How long did your ESP32 connect to AP? Is it sure to happen or happen by chance?

xzwang
Posts: 22
Joined: Wed Dec 14, 2016 4:54 am

Re: Crash happen after connect AP long time

Postby xzwang » Wed Feb 22, 2017 1:35 am

Hi,ESP_puff

ESP32 has keep connection for several hours. and the crash can reproduce.

The Situation:
1,ESP32 is listening BLE advertising constantly.
2,ESP32 enable WIFI and connect AP.
3,Disable use dual core for FreeTROS in sdkconfig.
4,After several hours, ESP32 received "SYSTEM_EVENT_STA_DISCONNECTED". It may caused by 'I (19830063) wifi: bcn_timout,ap_probe_send_start', just my guess.
5,In my project, ESP32 will do "esp_wifi_connect()" automatically if received "SYSTEM_EVENT_STA_DISCONNECTED".
6,If connect AP again, the crash will not happen. However, if it can't connect AP for sometime, the crash will happen.

This is my ESP32 usage scenario, I hope it can help.
Thanks.

Ansics
Posts: 8
Joined: Mon May 22, 2017 11:27 am

Re: Crash happen after connect AP long time

Postby Ansics » Fri Jun 02, 2017 7:57 am

Facing same problem.
Have any one troubleshoot this problem.

rinripper
Posts: 8
Joined: Wed Jun 28, 2017 3:52 am

Re: Crash happen after connect AP long time

Postby rinripper » Fri Jul 21, 2017 4:28 am

hi guys, someone have a solution for this? I am facing this after a long time connected...

Code: Select all

I (1374096) PERCEPTIVE CLIENT: SYSTEM_EVENT_STA_DISCONNECTED
I (1433091) wifi: n:6 2, o:6 0, ap:6 2, sta:6 2, prof:6
I (1433091) wifi: state: init -> auth (b0)
W (1433092) wifi: alloc eb len=32 type=3 fail

W (1433093) wifi: m f auth

I (1434096) wifi: state: auth -> init (2)
I (1434096) wifi: n:6 0, o:6 2, ap:6 2, sta:6 2, prof:6
I (1434096) PERCEPTIVE CLIENT: SYSTEM_EVENT_STA_DISCONNECTED 
I (1493091) wifi: n:6 2, o:6 0, ap:6 2, sta:6 2, prof:6
I (1493091) wifi: state: init -> auth (b0)
W (1493092) wifi: alloc eb len=32 type=3 fail

W (1493093) wifi: m f auth

I (1494096) wifi: state: auth -> init (2)
I (1494096) wifi: n:6 0, o:6 2, ap:6 2, sta:6 2, prof:6
I (1494097) PERCEPTIVE CLIENT: SYSTEM_EVENT_STA_DISCONNECTED
I (1553091) wifi: n:6 2, o:6 0, ap:6 2, sta:6 2, prof:6
I (1553091) wifi: state: init -> auth (b0)
W (1553092) wifi: alloc eb len=32 type=3 fail

W (1553093) wifi: m f auth

I (1554096) wifi: state: auth -> init (2)
I (1554096) wifi: n:6 0, o:6 2, ap:6 2, sta:6 2, prof:6
I (1554096) PERCEPTIVE CLIENT: SYSTEM_EVENT_STA_DISCONNECTED
I (1613091) wifi: n:6 2, o:6 0, ap:6 2, sta:6 2, prof:6
I (1613091) wifi: state: init -> auth (b0)
W (1613092) wifi: alloc eb len=32 type=3 fail

W (1613093) wifi: m f auth
I need help, thanks in advance

Who is online

Users browsing this forum: No registered users and 31 guests