Using Ethernet without WiFi enabling gets undefines

User avatar
rudi ;-)
Posts: 1293
Joined: Fri Nov 13, 2015 3:25 pm

Using Ethernet without WiFi enabling gets undefines

Postby rudi ;-) » Tue Feb 21, 2017 10:50 pm

hi guys

testing the ethernet example just in time

preview question:
can we use Wifi and Ethernet at same time?
must we use Wifi ( enabling ) if we use Ethernet?
wifi_ethernet.png
wifi_ethernet.png (12 KiB) Viewed 3905 times
cause:
------

i tried to disable WiFi in menuconfig and get few undefines.

undefined reference to `esp_wifi_internal_reg_rxcb'
undefined reference to `esp_wifi_get_mac'
undefined reference to `esp_wifi_internal_set_sta_ip'
undefined reference to `esp_wifi_internal_free_rx_buffer'
undefined reference to `esp_wifi_internal_tx'

..
CC port/esp_sha1.o
AR libmbedtls.a
LD ethernet_demo.elf
C:/nod/ethernet/ethernet/build/esp32\libesp32.a(event_default_handlers.o):(.literal.system_event_ap_stop_handle_default+0xc): undefined reference to `esp_wifi_internal_reg_rxcb'
C:/nod/ethernet/ethernet/build/esp32\libesp32.a(event_default_handlers.o):(.literal.system_event_ap_start_handle_default+0xc): undefined reference to `esp_wifi_get_mac'
C:/nod/ethernet/ethernet/build/esp32\libesp32.a(event_default_handlers.o):(.literal.system_event_sta_got_ip_default+0xc): undefined reference to `esp_wifi_internal_set_sta_ip'
C:/nod/ethernet/ethernet/build/esp32\libesp32.a(event_default_handlers.o): In function `system_event_ap_stop_handle_default':
C:/sdk32/esp-idf/components/esp32/event_default_handlers.c:183: undefined reference to `esp_wifi_internal_reg_rxcb'
C:/nod/ethernet/ethernet/build/esp32\libesp32.a(event_default_handlers.o): In function `system_event_sta_disconnected_handle_default':
C:/sdk32/esp-idf/components/esp32/event_default_handlers.c:245: undefined reference to `esp_wifi_internal_reg_rxcb'
C:/nod/ethernet/ethernet/build/esp32\libesp32.a(event_default_handlers.o): In function `system_event_sta_connected_handle_default':
C:/sdk32/esp-idf/components/esp32/event_default_handlers.c:213: undefined reference to `esp_wifi_internal_reg_rxcb'
C:/nod/ethernet/ethernet/build/esp32\libesp32.a(event_default_handlers.o): In function `system_event_ap_start_handle_default':
C:/sdk32/esp-idf/components/esp32/event_default_handlers.c:235: undefined reference to `esp_wifi_internal_reg_rxcb'
C:/sdk32/esp-idf/components/esp32/event_default_handlers.c:173: undefined reference to `esp_wifi_get_mac'
C:/nod/ethernet/ethernet/build/esp32\libesp32.a(event_default_handlers.o): In function `system_event_sta_start_handle_default':
C:/sdk32/esp-idf/components/esp32/event_default_handlers.c:176: undefined reference to `esp_wifi_get_mac'
C:/sdk32/esp-idf/components/esp32/event_default_handlers.c:199: undefined reference to `esp_wifi_internal_set_sta_ip'
C:/nod/ethernet/ethernet/build/lwip\liblwip.a(pbuf.o):(.literal.pbuf_free+0x0): undefined reference to `esp_wifi_internal_free_rx_buffer'
C:/nod/ethernet/ethernet/build/lwip\liblwip.a(pbuf.o): In function `pbuf_free':
C:/sdk32/esp-idf/components/lwip/core/pbuf.c:1253: undefined reference to `esp_wifi_internal_free_rx_buffer'
C:/nod/ethernet/ethernet/build/lwip\liblwip.a(wlanif.o):(.literal.low_level_output+0x0): undefined reference to `esp_wifi_internal_tx'
C:/nod/ethernet/ethernet/build/lwip\liblwip.a(wlanif.o): In function `low_level_output':
C:/sdk32/esp-idf/components/lwip/port/netif/wlanif.c:117: undefined reference to `esp_wifi_internal_tx'
C:/sdk32/esp-idf/components/lwip/port/netif/wlanif.c:122: undefined reference to `esp_wifi_internal_tx'
collect2.exe: error: ld returned 1 exit status

a second thing (puzzled):
ip_4_ethernet.png
ip_4_ethernet.png (42.91 KiB) Viewed 3905 times

the ethernet example calls tcpip_adapter_init();
https://github.com/espressif/esp-idf/bl ... ain.c#L164

this calls
https://github.com/espressif/esp-idf/bl ... lwip.c#L48
and there we address to ap ( btw ap without WiFi enabled brings undefines ? )

missing the "TCPIP_ADAPTER_IF_ETHERNET" and IP Setting, where we get our "ETH" IP Address ?

btw we have a check on :
https://github.com/espressif/esp-idf/bl ... wip.c#L679

best wishes
rudi ;-)
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

User avatar
rudi ;-)
Posts: 1293
Joined: Fri Nov 13, 2015 3:25 pm

Re: Using Ethernet without WiFi enabling gets undefines

Postby rudi ;-) » Wed Feb 22, 2017 10:44 pm

Angus wrote: Also, please remember it may take more than 24 hours to get a reply from an Espressif employee.
push
+1

i will in future every theme push now after 24 h no answering
until we get a response!

we sitting here and must wait?

it is a developer forum -
about.png
about.png (5.17 KiB) Viewed 3872 times
why we allways must call for paper in wait while?

it makes no fun in this combine to say allways to our own developers
"it's pending - go home for this day, no answere just in time"


:evil:
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

ESP_Angus
Posts: 1617
Joined: Sun May 08, 2016 4:11 am

Re: Using Ethernet without WiFi enabling gets undefines

Postby ESP_Angus » Wed Feb 22, 2017 10:57 pm

rudi ;-) wrote:
Angus wrote: Also, please remember it may take more than 24 hours to get a reply from an Espressif employee.
push
+1

i will in future every theme push now after 24 h no answering
until we get a response!
I stated that it may take longer than 24 hours to respond, so annoying us every 24 hours is both contrary to my statement and counter-productive. We're all busy employees doing our best here. I had your post open in a tab, and I was hoping to look at it today if I don't get bogged down in other tasks.

Please do not make "push" posts of this kind again.

User avatar
rudi ;-)
Posts: 1293
Joined: Fri Nov 13, 2015 3:25 pm

Re: Using Ethernet without WiFi enabling gets undefines

Postby rudi ;-) » Wed Feb 22, 2017 11:04 pm

Angus

we are 23 developers here in our company every day
we are still sitting here for simple answeres on posted coded examples to work further on this.

ethernet example is the best example
it do not run!



who has this example made?
can you please provide the shematic on this example
and reference to used esp32 board?

can you please organice in future with samples
that used hardware is described in the readme
and used shematic is posted in the repo?
thank you!

i can not believe that this example runs in this form of code
sry!
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

User avatar
rudi ;-)
Posts: 1293
Joined: Fri Nov 13, 2015 3:25 pm

Re: Using Ethernet without WiFi enabling gets undefines

Postby rudi ;-) » Wed Feb 22, 2017 11:05 pm

ESP_Angus wrote: Please do not make "push" posts of this kind again.

i will push every theme after 24h

if you not like, delete the push posting

again:
if you delete my postings, delete my account
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

ESP_Sprite
Posts: 2691
Joined: Thu Nov 26, 2015 4:08 am

Re: Using Ethernet without WiFi enabling gets undefines

Postby ESP_Sprite » Thu Feb 23, 2017 1:13 am

C'mon, Rudi, you seem like a guy who is used to developing stuff yourself, you must know how frustrating it can be if you get distracted from what you're doing all of the time. That's essentially what you're doing with us if you kick your post every 24 hours. I think Espressif is fairly unique in having a tech forum where the core developers hang around themselves to answer questions... that comes with good things (really in-depth answers straight from the devs) but also comes with some bad things (sometimes it takes us a while to react). I ask you to just respect that; the way we work now is the way we get most work done on esp-idf while still being able to answer questions on the forum, so we aren't about to change it.

Now, I can be all heavy-handed and add something to the forum rules saying no topic kicking and delete your post, but I'd rather you accept that we just work this way and sometimes it'll take more than 24hrs to get a dev working on an issue. Feel free to ask if we overlooked your topic after say three days or so, but please do act like we owe you an answer within 24 hours.

ESP_Angus
Posts: 1617
Joined: Sun May 08, 2016 4:11 am

Re: Using Ethernet without WiFi enabling gets undefines

Postby ESP_Angus » Fri Feb 24, 2017 4:36 am

At the moment, to use ethernet WiFi must be enabled in the configuration. This is a bug, and there is a fix currently being reviewed and tested. Once that is merged, it will be possible to enable Ethernet only.

In the meantime, if WiFi is enabled in configuration but unused (ie no esp_wifi_start(), etc.) then the firmware will be larger than necessary in flash but the runtime overheads are extremely small.

Regarding using Ethernet & Wifi simultaneously, this is possible. I put this reply into a new thread on the SDK forum: https://esp32.com/viewtopic.php?f=13&t=1274

User avatar
rudi ;-)
Posts: 1293
Joined: Fri Nov 13, 2015 3:25 pm

Re: Using Ethernet without WiFi enabling gets undefines

Postby rudi ;-) » Fri Feb 24, 2017 8:59 am

ESP_Angus wrote:At the moment, to use ethernet WiFi must be enabled in the configuration. This is a bug, and there is a fix currently being reviewed and tested.
thank you
-------------------------------------
love it, change it or leave it.
-------------------------------------
問候飛出去的朋友遍全球魯迪

Who is online

Users browsing this forum: Baidu [Spider], Daveyman123, YaCy [Bot] and 19 guests